Supra Forums banner
1 - 6 of 6 Posts

· Registered
Joined
·
448 Posts
Discussion Starter · #1 ·
OK, I'm about to replace the front passenger wheel bearings for my MKIV and have removed the 3 bolts/nuts that hold the sterring knuckle/hub that connects to the rotor. The problem now is:rolleyes: I can't remove the knuckle. I tried tapping it from the top, I've tried lifting it up, but nothing budges. Am I doing something wrong? Has anyone removed it before? Any help would do, thanks in advance!
 

· Registered
Joined
·
448 Posts
Discussion Starter · #3 ·
Yes. They are pressed in. You need to use tools that look like this.

http://www.matcotools.com/ProductImages/mst6295.jpg

Then the pressed in parts, tie rod, ball joints, pop off, and the knuckle comes off.
Thanks! What are they called again? Where can I get these things? Does an Auto Zone carry or loan out tool them? Man, this is turning out to be a pain in the *ss. I'm planning on taking the knuckle to a mechanic and letting them press in and out the bearing. Hopefully it turns out good. Thanks for the quick response again!
 

· Registered
Joined
·
748 Posts
Ball joint separator. It should be available from any auto parts store. The one farthest on the right in the picture above (lever and bolt) is what you need. Do not use the fork type that you just hammer on to wedge the ball joint out. It will mess up the grease boot. You need to be careful with any separator not to damage the boot.
 

· Registered
Joined
·
448 Posts
Discussion Starter · #5 ·
Finally had some time and manged to get that wheel knuckle/hub off. Those tools above worked great! Only question I have is how much play should the hub have? After taking it to a local mechanic, I noticed the turns on the hub are a bit harsh or hard to spin (unlike the driver's front side). I also notice a weird rubbing sound as I spin the hub, is this normal since it's a new bearing and seal? How can I know if the pressing of the bearing and everything else was done correct? The mechanic said theirs basically a one way in and out installation, and that here is no way it can be installed wrong :doh: . Anyway, while putting back one of the below arms that connect to the knuckle I noticed one of those rubber black bushings has tan grease coming out from where I tighten the nut/bolt. I hope I did not tighten it to much. I hope it's jut me seeing sh*t. Thanks in advance!
 

· Registered
Joined
·
476 Posts
on all cars ive changed out balljoints like that you cant overtighten them to the point where grease comes out, because theres a machined sufface before the rubber that it stops on. but the color and greases you mentioned sounds alot like the content of balljoints.. sure you didn't puncture it somehow ?? I would check again and change it out if you did.. try squeesing it gently to see if something comes out.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top