Supra Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
54 Posts
Discussion Starter #1
im about to go do my manifold gaskets so i can finally drive my supra. any tips or tricks to taking this manifold off? its the 7mgte
 

·
Registered
Joined
·
54 Posts
Discussion Starter #3
Alright I've got the upper off. Wasn't too bad. The lower however looks somewhat harder. I noticed some fuel? and oil residue in the runners which makes me kind of nervous. Any reason that'd be there? Also I've taken apart many motors in my life and im seeing some things on this I've never seen before. The main thing is a wand type thing that bolts to the underside of the manifold and sticks up inside it right behind the throttle body. I think it was fuel coming out of the banjo bolt when I removed it. What is the purpose of this part?
 

·
Registered
Joined
·
54 Posts
Discussion Starter #5
What's that plunger thing that bolts to the manifold? Like right next to the tps. The manifold is done now but its still sucking in air from somewhere and it really sounds like its coming from that thing.
 

·
Banned
Joined
·
4,966 Posts
Got swivel sockets?



Will make your life easier when tackling the EGR.
 

·
Registered
Joined
·
54 Posts
Discussion Starter #8
haha yeah ive already put those swivels to use. if the IAC was to go bad would it be giving me that terrible leak sound? when i start it the idle is extremely choppy and then it like snaps out of it and revs up to like 2 grand and holds for a few seconds then drops back down and is so choppy that it almost wants to shut off but it doesnt. then it just revs up again and itll keep on going in cycles like that for as long as i have it running.
 

·
Registered
Joined
·
54 Posts
Discussion Starter #9
after a little research im beggining to believe maybe it is not my IAC. it seems like the noise that sounds like a vacuum leak is just an operating sound of the engine. when i pulled off the vacuum hose at the accordion to the IAC and plugged it with my finger the car just shut off, and it clicks when shut down. now i pulled off the MAF plug and the car idled perfectly. it just wasnt too happy about me hitting the throttle but that was expected. could the MAF be at fault?
 

·
Registered
Joined
·
54 Posts
Discussion Starter #11
Thanks guys I really appreciate all the help. That page is amazing. I've been dying to get a supra since I started driving 5 years ago and now I have one so I just wanna get it fixed so I can drive it.
 

·
Banned
Joined
·
4,966 Posts
Yeah, my intake manifold gasket is leaking air (at the head), I just got a new one from Yota, but I think I'll change it tomorrow.
 
1 - 13 of 13 Posts
Top