Supra Forums banner
1 - 15 of 15 Posts

·
got boost???
Joined
·
1,362 Posts
Discussion Starter · #1 ·
how hard is it to remove the stock sender to put an aftermarket one in? is there room below the car to reach it? what tools would i need? i don't want to start it and then not being able to finish it...
 

·
got boost???
Joined
·
1,362 Posts
Discussion Starter · #2 ·
ok i took a look....where is the oil pressure sender? went below since ppl said its next to the filter..didn't see any?
 

·
Registered
Joined
·
3,123 Posts
It is on the passenger side of the block near the front. Here is a pic from the TSRM (last pic) to give you an idea of its location and what it looks like:

http://www.cygnusx1.net/supra/library/TSRM/lu/LU_04.gif

The sender is a goldish colour, but it will most likely have a grey rubber cover over it, as well as a coated wires. HTH.
 

·
got boost???
Joined
·
1,362 Posts
Discussion Starter · #4 ·
ok i think i actually saw the grey cover and didn't think that wasit....but it seems like it will be a bitch to get at it....do i have to remove the oil filter before i can get to it..even after that can i have access to it?
 

·
Registered
Joined
·
3,123 Posts
Here is the sensor (circled in green)



You can get to it without removing the oil filter, at least on a turbo engine.
 

·
got boost???
Joined
·
1,362 Posts
Discussion Starter · #6 ·
u can get it from below or top? it seems like there isn't any space at all....do i need to take out the intake pipe from top or what?
 

·
Supra Fan
Joined
·
4,114 Posts
removing(or unbolting and pushing it out the way) the p/s reservoir and bracket will be a must, as well as the other obvious crap like intake pipe etc..
 

·
got boost???
Joined
·
1,362 Posts
Discussion Starter · #8 ·
ok thats what i thought....i wasn't sure as i thought i could just reach arond sometihng and unbolt it....i guess i'll finish the oil pressure gauge wire when i do my IC install next week...thanks
 

·
Buddy thought I had a NA
Joined
·
2,476 Posts
its' 10 mill or 12 mill i cant remmber but there on tight well alt lest mine was an it was pain to take off

short wreanches are your friedn but if you got to talke it off broek or not just just vise grips o the thign its self and it may come off
 

·
got boost???
Joined
·
1,362 Posts
Discussion Starter · #10 ·
yea i pulled everything off, intake, AFM, and unbolted the PS and i can see how hard it is to fit a wrench in there.....i pulled off the cap and the wire running to it...wen the wire came off i thought i broke it :sadwavey: so i was like fuck i guess i should really try to install the autometer one..but after messing for 20 minutes trying to fit a wrench in there iit just doesn't work..luckily the stock one wasn't broken it was just me bieng stupid and i could plug it right back in .i need a short wrench and try to take it off....yes i'm lazy and i need the car tomorrow so i put everything back together and give it a try again next weekend
 

·
Stock Boost SUX
Joined
·
1,660 Posts
Its definately a bitch. Im not lookin foward to fuckin with it when I get some gauges.
 

·
No One Ever Listens To Me
Joined
·
5,467 Posts
supratkfy said:
yea i pulled everything off, intake, AFM, and unbolted the PS and i can see how hard it is to fit a wrench in there.....i pulled off the cap and the wire running to it...wen the wire came off i thought i broke it :sadwavey: so i was like fuck i guess i should really try to install the autometer one..but after messing for 20 minutes trying to fit a wrench in there iit just doesn't work..luckily the stock one wasn't broken it was just me bieng stupid and i could plug it right back in .i need a short wrench and try to take it off....yes i'm lazy and i need the car tomorrow so i put everything back together and give it a try again next weekend
did you get the adaptor you need to run the autometer sender? if not it wont even screw into the block ;)

yeah that sender is a HUGE PITA....i waited till my engine was out to install it ;)
 

·
got boost???
Joined
·
1,362 Posts
Discussion Starter · #13 ·
yeap i got the autometer but i thought it would be easier since everyone said its near the oil filter...guess not...
 

·
Registered
Joined
·
409 Posts
whenever i need to get to it to remove it or whatever i drop the power steering pump. i leave the lines hooked up though, and just hold it off to the side with a bungee cord. i also pull off the lower turbo IC pipe, and that seems to make it relatively simple. and FYI the fitting that autometer includes in the mechanical oil pressure gauge package won't work. you need to get an adapter from somewhere, a BSP to NPT i believe. i went to a hydraulics/fluid power industrial warehouse and the guy gave me the part for free. after that it was smooth sailing. hope this helps.
 

·
got boost???
Joined
·
1,362 Posts
Discussion Starter · #15 ·
yea i got the adapter....taking it off and putting it on is the problem now..i'm gonna wait when i install my fmic and have to ake off the lower pipe before doing it
 
1 - 15 of 15 Posts
Top