Supra Forums banner

1 - 7 of 7 Posts
S

·
Guest
Joined
·
0 Posts
Discussion Starter #1
Whatup Supraholics. My question,Silly as it may sound needs a prompt reply. I just got my car out of the shop after having some engine work done .But the problem I'm having is it stalls on me . Like when I come to a light or stop sign sometimes it just shuts off . did anyone experince this problem and if so how did you correct it . Get at me
 

·
Republican
Joined
·
8,421 Posts
can you give us more of a discription? turbo or not? what did the shop do? miles? mods? its hard to diagnose a problem when you dont give us background info!;)
 
W

·
Guest
Joined
·
0 Posts
Discussion Starter #3
is the engine just stalling? electrical cutting out? flooding out?
 
S

·
Guest
Joined
·
0 Posts
Discussion Starter #6
Hey guys thanks for all the info. Today i'm gonna do what we call the process of elemenation . Starting with changing all the vacuum hoses and lines. I also have an after market BOV I'm gonna put on it.I will keep you guys informed of the progress.
 
S

·
Guest
Joined
·
0 Posts
Discussion Starter #7
This is a little back ground info on my car . Shes a 1990 turbo targa I bought it off a friend of after he let it sit for two years with a blown head gasket. The shop I took it to was a little shady. Meaning he took some short cuts to fix my car . Oh well you live and learn!. The car runs pretty good but there's the little things that needs to done. As in I'm no hurry to drive it .It gives me time to run through it and make sure its right.So when I do take her out OH BOY... Honda's please move to the side....
 
1 - 7 of 7 Posts
Top