Supra Forums banner

1 - 20 of 31 Posts
R

·
Guest
Joined
·
0 Posts
Discussion Starter #1
Ok these are my numbers.

294rwhp & 259tq. 1997 auto bpu, 91 octane, with many problems with my car.

s-afc2 still untuned

Greddy Profec B spec2 installed incorrectly from Bozz Performance

Greddy BCC might be installed incorrectly from Bozz Performance

Stutter feeling stll there but were not sure if its the plugs or fuel cut or boost cut or whatever.

Not getting instant boost.
example----> 3700rpm im getting 13psi. Finaly reach 17psi @ 5600rpm. WTF?

A guy before me has a 94 red auto bpu and he was getting 16psi from 3500rpm and stayed up at 16psi all the way to redline.

Henry @ MSD said my car is falling on its face at higher rpm.

Gotta take it back on Thursday to spend more freaken money to make things right.

If anyone can inlighten me with some knowledge on what the fuck is going on with my car please do so.

Thanks Romeo
 

·
Yes, brothers own Supras
Joined
·
1,910 Posts
Post the graph. Did u use a wideband? With that crappy 91 gas the ECU was probably pulling timing. If the BCC wasnt working then u wouldnt be able to get over 14.5 psi. Did u run new plugs? What was the gap? Alot more info is needed if u want people to help you.
 
R

·
Guest
Joined
·
0 Posts
Discussion Starter #4
I re-gaped it to .028 and they are 2weeks old. I will try to post the graph but need to find someone to scan it and post it for me because I don't have a scanner. Dynopack was used as far as I know.
 

·
Republican
Joined
·
8,421 Posts
Wow, thats a really low number! and how the heck do you instal a profec b incorrectly!?
 

·
How does my exhaust smell
Joined
·
1,014 Posts
Where are you located? It might help to have a couple of local Supra guys check out your car to see if there is any obvious things wrong. You would be suprised.
 

·
Registered
Joined
·
1,936 Posts
Romeo,
Did anything change recently before you dynoed? You mentioned you smoked an 03 Cobra and you have a strong BPU -what changed from then to now? Did you race him on 91 octane?
 
R

·
Guest
Joined
·
0 Posts
Discussion Starter #8
earl3 - The 03 Cobra that I race was a guy my friend knows and we race from a dig and that was only like a couple of weeks ago. He is bone stock and I took 1 car length right after 1st gear and it stayed that way all the way to 110mph or so. And nothing changed since I raced him and it was on 91octane because California sucks. We race twice actually and same result as the 1st race.

Bad4URHeart - Im in sacramento california(citrus heights by sunrise mall if you know where that is). I would love for fellow local Supra owners to check out my car before I send it back to Motorsports Dynamics. I re-sechedule with them because I couldnt drop off the car or pick it up on thursday(12-11-03).

CKanderson - Henry @MSD said that most shop will go by the directions that are wrong for the MKIV. He told me from years of experience that you have to bypass a selinold or something like that. He said that your suppose to have it hooked up to both turbo's. The graph does show that my spool or lack of getting boost is very slow as if the 2nd turbo is not getting pressure or something like that.

I know that my car is putting out more than what it said. Like I stated before their was a guy with a 94 red auto bpu with s-afc2 just tuned and he only dyno'ed at 306rwhp or so. He told me that he was putting out more than that at another dyno place and he was putting out something like 340rwhp before the tuning of the s-afc2. Also he ran a 12.7 @ 118mph. It is known that the dyno at MSD does read out lower numbers then other dyno so Im not to worried about the low numbers. What I am worried about is if I need to spend another $250 plus for him to re-install the profecB spec2. Funny thing was that when he was saying that it was falling on its face at higher rpm and after looking at the graph more and more I notice that it might just be my ebc working how its suppose to.
I have it set at 1.25 kpa x100 and the boost warning feature at 1.25 kpa x100 which equals out to a 18psi or so. What the warning feature do is when its activated(when b0ost reach the setting limits) it drops the boost down to a safe area but what I don't get is on the graph it had the boost dropping down very low and the rpm going backwards too as if Henry was letting off on the gas cause of this suppose boost cut that he think is the problem.

If there is any knowledgable MKIV tt owners in the area please take a look at my car and help a brother out. And if anyone was curious on why I just dyno'ed with 91octane only is because I just wanna see what it puts out in the real word.(I mean I don't really put in racing gas when Im driving my car everyday). I just wanna get the s-afc2 tuned and then when said and done I will be taking it to a dynojet and putting in half 91 and half 110 and ice the intake and everything and give it hell just to see what numbers I can get with prep work.

And yes Im sorta of pondering on how a ebc can be installed wrong. Does anyone have any idea why Henry said this?
I think the reason why he said this is that Im not getting boost instantly.

If I forgot any info for you guys to help me out let me know.
 

·
Registered
Joined
·
92 Posts
I am the guy with the red 96 supra TT automatic. At midnight performance(the local dynojet machine) I was putting down 345 RWHP at 16lbs of boost on stock plugs in 100 degree heat. With those #'s, I'd trap about 109mph or so. Since then, I changed my plugs(good for 113mph) and obviously had henry tune my safc2(not yet run). With that done at 45 degrees out henry's machine said I was putting down 306, prior to the tune, the same setup that got me a 113mph trap speed, his machine said I was putting down about 285. Obviously reading very low, but it seems to be a pretty good machine for tuning. I was a bit dissapointed too, I could only lean out to around 11.2 before I started to audibly detonate. At an 11.5 AFR my car was pinging bad. Could be the piss water we use for gas, or my obd2 ecu, maybe just a bad tank of gas, not really sure. I've got colder plugs gapped down, and the standard BPU mods.
 
R

·
Guest
Joined
·
0 Posts
Discussion Starter #10
JHSPayBar- Hey did Henry say anything to you about your ebc installation. He is telling me mine is done wrong. Who install you ebc? Can we meet up sometimes and check to see if I need to reinstall my ebc because I don't wanna have to spend more money and time if i don't need to. He was showing me your dyno and how you stayed up at 16psi all the way to redline. Do you know if your ebc is installed to both turbos rather then just the 1st? Yeah and shitty part about it is that I spent $212 for nothing(didnt even get the s-afc2 tuned) Hey if you know how to read yours or if I can hook up with you could I copy your s-afc2 numbers considering that you gain a bit of rwhp from it. Any help would be cool.
 
R

·
Guest
Joined
·
0 Posts
Discussion Starter #11
Ok Correct me if Im wrong guys.

-Rome(me) dyno'ed 294rwhp @ 17psi on 91octane only.

-JHSPayBar dyno'ed 285rwhp @ 16psi on 91octane I think.

-Both gapped with fairly new ngk6097 plugs at .028

-My car went right after his so not much difference in weather and condition. Only difference is he is holding boost.

JHSPayBar dyno'ed 345rwhp @ 16psi at midnight performance on stock plugs and Im assuming 91octane and s-afc2 untuned.

JHSPayBar went to Motorsports Dynamics dyno'ed 306rwhp with the s-afc2 tuned. So he gained about 21rwhp with the s-afc2 tuned with new plugs.

So if you take his orginal 345rwhp at midnight performance and add the 21rwhp gained with the s-afc2 tuned than he would have
366rwhp. And with new plugs gapped right I say a gain about maybe 2-5rwhp(im guessing because he trapped higher with the new plugs). So give or take he would have about 366rwhp to 370rwhp on 91octane at 16psi.

Ok and I know my bpu is not weak at all. So if I dyno'ed 294rwhp with 91octance @ 17psi and s-afc2 not tuned yet then I would equal out to something simaliar to JHSPayBar. So Im assuming with some race gas I would dyno maybe into the 400rwhp zone once everything is cleared up with my car.

If Im wrong in any sense feel free to tell me so.
 

·
Old School
Joined
·
4,055 Posts
Rome_The_Supraman said:

CKanderson - Henry @MSD said that most shop will go by the directions that are wrong for the MKIV. He told me from years of experience that you have to bypass a selinold or something like that. He said that your suppose to have it hooked up to both turbo's. The graph does show that my spool or lack of getting boost is very slow as if the 2nd turbo is not getting pressure or something like that.

Perhaps you misunderstood Henry, but you do NOT connect an EBC on stock twins to both turbos, only to the wastegate that is on the first turbo, the one nearest the front of the car.

Use the directions from mkiv.com for the Blitz DSBC, all you need to do is pay attention to the way the solenoid is connected, the way it's described in the link below is correct for all EBC's.

It's not at all hard to do yourself.

Click here for EBC directions
 

·
Registered
Joined
·
92 Posts
I have an AVC-r, and it is only connected to the wastegate, not both turbo's. I have heard of some places connecting it to the wrong turbo VSV I believe causing boost to be sporadic and hard to hold. My plugs likely picked me up around 10-15rwhp, if not more, I trapped 4mph faster on the plugs changed alone.

Will
 
R

·
Guest
Joined
·
0 Posts
Discussion Starter #14
If I remember correctly Henry said that he said it is suppose to be connected to the front wastegate aculator and back as well.
 

·
Old School
Joined
·
4,055 Posts
Rome_The_Supraman said:
If I remember correctly Henry said that he said it is suppose to be connected to the front wastegate aculator and back as well.
Don't let him connect your EBC like that, and for God's sake don't pay him to do it that way.

That's the common, and wrong way to do it that causes the 1st turbo to overboost while you lose pre-spool to #2. The instructions that accompany the EBC's from Japan show that method. Wrong, wrong, wrong. :)

Hook it up as described in the www.mkiv.com Tech Articles section.
 
R

·
Guest
Joined
·
0 Posts
Discussion Starter #16
Yeah I was like wtf when he said he wanted to re-install it and was gonna charge me $250 for that. Then he said that he's gonna look at my BCC and maybe reconnect that cuz he think im hitting boost cut and charge me more for that. He told me that he suspect the BCC is done wrong to cuz when he dyno'ed it he couldnt pass 17psi but the funny thing is I got my car up to 1.34 kpa x100 which is well above 19psi already so I was like wtf. So I know the BCC is doing its job. He also said I need new plugs but my plugs only have 500 miles on them.(wtf) Also he would take a look at my car to see if any other little problems might accure but will charge me to look at it.(wtf)

It was funny he said ''95% of tuners out there does it the wrong way because they follow the direction given from japan''.

For a fact I know that the stuttering feeling that he think is boost cut is cuz of my plugs. I mean if my shit is not done correctly then how the hell do you explain my SUPER FAST LAUNCH lol.:D

Lagtime you sound like you know what your talken about.
Can anyone 2nd his opinion so I would feel more re-assured and not take it back there and have them work on my car and waste alot more money.
 
R

·
Guest
Joined
·
0 Posts
Discussion Starter #17
Ok I just got back from testing my car out because the road are finally dry. Ok for some reason my car feels slower. I mean it still feels fast but not the feeling I was use to were it sorta throws you back to your seat feel. I was like oh shit what is going on. I couldn't figure out why it doesnt pull as hard as it use to after taking it to Motorsports Dynamics. Then I thought to myself lets unplug the s-afc2. Ok after disconnectiong the s-fac2 I let my car have it and it went back to normal. I was not 100% sure if that was the reason so I just went back and forth on madison and some in side road around my house. After numerous attempts gunning it at a dig and flooring it at WOT with the s-afc2 pluged and unpluged I knew for a fact that its the s-afc2. There was a big difference on the response when I unpluged it. I really don't know how to read that fuel system and I never played with it so.... Ok so my car is feeling fine before I take it to MSD and after when they told me that they didn't tune the s-afc2 at all why the hell does my car feel slower with the s-afc2 pluged in? Im trying not to point finger at anyone but why would it do this after taking it to a shop for them to dyno tune something and they never did because of other issues. Also the funny thing is I recently notice that they left some wire hanging from my downpipe where they welded a bung thing so they can read the a/f.

So before taking it to MSD my car is running fine to my knowledge and the only thing really wrong with it is the stutter feeling because of the gapping of the spark plugs. And then after getting it back from them I get news of my ebc is done wrong, my bcc is done wrong, I need new plugs, need to fix it all and take it back so they can tune the s-afc2 and charge me again for it.

Is there any other tuners in north cali you guys recommmend?
Im at the point were Im sick of bs like this.
 

·
Registered
Joined
·
37 Posts
Rome.. a couple of things:

1st...I will second Lagtime on the installation of your ebc. DO NOT have them connect it to your 2nd turbo...that actuator is for pre-spool, NOT a wastegate actuator!!!! No wonder I people get so damn frusterated with shops...I actually used this link for installing my GReddy E-01:http://www.mkiv.com/techarticles/avc-r/install/index.html and it works perfectly (of course except the usual BPU boost creep that everyone has in cold weather)...
2nd..your BCC maybe connected correctly, but needs to be tuned to the right output voltage..see this link:http://www.mkiv.com/techarticles/bcc/bcc_install/bcc_intro.htm I don't know how to check it already in the car, since I adjusted mine before I installed it by just connecting it to my 14v cordless drill battery :) and using a volt meter...
3rd..can't help with the s-afc2 since I don't have one...if it feels different with it disconnected, maybe they did do some adjustments to it without your knowledge...

As for a tuner in North Cali check in the Cal Forum, there is a sticky with the number to ATP in Fremont...they have a good rep, though I personally have only bought parts from them and they are very quick and helpful....and on just a quick opinion, if these guys at the shop you did go to don't know something as simple as hooking up an ebc to your car correctly, I might not trust them to tune my fuel ratio, if they screw that up, bye bye block....my 2 cents...
 

·
Registered
Joined
·
92 Posts
Henry is one of the best supra tuners in northern california. He has guys from the bay area and even farther bring cars to him to work on. I've probably seen 5+ single turbo conversion supra's being installed and tuned in the few months I've been visiting his shop. While I was there on tuesday he had an N/A supra on the lift getting turboed, so he knows what's going on. The first time I went to get dyno tuned henry said my car needed plugs, and he was right, I got 3-4mph from plugs alone. Upon taking the car back in, he tuned it perfectly, he knew that most BPU's like it at 11.5 and starting leaning my car out to that point, when I began to detonate around 11.3 afr he pulled it back down in the 11.1-11.2 range and the car put out it's best power. Henry knows what is going on, but remember, he is trying to sell you more stuff, their special spark plugs etc... so you can always fix the things yourself if he says they're wrong, that's what I did, and I took it back to get tuned. He's never fibbed about a problem on my car, when he says something needs to be fixed he's right.
 
R

·
Guest
Joined
·
0 Posts
Discussion Starter #20
Then can you explain to me why my car feels slower now?
Can you explain why he wants to re-install my ebc a different way?
I am not saying he doesn't know what he is doing but I know he is in it to make money.

I mean I know if people bring alot of cash he will take care of them. The na that he has up is gonna spend more the 7k just to let u know that much because I had a na once and I already tryed to go that route.

For the records my plugs only have 500-700miles on them and that is by no means old plugs.

Can I get anyone else to 3rd or 4th the notion of Lagtime knowledge?
 
1 - 20 of 31 Posts
Top