Supra Forums banner
21 - 31 of 31 Posts

· Registered
Joined
·
247 Posts
I have been going to henry for 6 years now and I have found that he often will make the WRONG call. Twice he told me my turbos where bad? I even got toyota to replace them under warranty only to find afterwords that they were fine. I have had other supra owners go there a get the same mis-diagnosis, So when the time came to go single I packed the car on a transporter and sent it to PHR and got it done right!! I have lost all confidence in henry and will do all i can to avoid going to him. Go to fremont go to so-cal go anywhere but MSD. I have a local mech that is the only person I now let work on the car and he is good. But does not have a shop only skills and tools but no dyno.
 

· DitchByTheSideOfTheRoad
Joined
·
494 Posts
I installed my Profect B using he blitz instructions on MKIV.com...Lagtime knows his shit and is a good guy...listen to him...I would say do it yourself...but dealing with an already messed up car you might need the help of another supra owner to compare against to get it back to the way it is suppose to be.

Might as well leave the s-afc off until you get your boost controller issues resolved...it will be safer...esp since you dont have no wideband in the car...

Also I did 349 rwhp at 1.1 bar. with what I believe a boost leak, but that was with 1/2 a tank of race gas.

Lates,
Brent
 
G

·
Discussion Starter · #23 ·
boostleak- By chance is there any chance you can take a look at my install and see if its done right. I think I know what Im doing but I just wanted a 2nd opinion in person with someone that knows and been there before. I think Im suppose to bypass the 2 holes and connect it straight to the front aculator. If you can pm me with you number so I can call you sometimes and meet up with you to see if you can help a bro out.

Thanks guy


I trust fellow MKIV owner over any shop. Romeo
 

· Registered
Joined
·
247 Posts
I would love to help but I had a shop do all my stuff. I am a worthless mech and i will only make it worse. I suggest that fremont shop or someone else on the forum who knows this stuff. My comments come from taking my car there and having it run like shit. and replacing the stock twins - twice :(
 
G

·
Discussion Starter · #26 ·
I just unplugged it from the connector and it runs strong. I even try today too when the roads where dry again in citrus heights.
Yup Im 105% sure that my car pulls much harder from a dig or from a roll with the s-afc2 unplugged from the connector. I even raced that 03 cobra again when I went over my friends house. I guess he was chillen with my buddy and we went to a open road and went at it. Lets just say he is not stock either because he told me he had and exhaust and airfilter or something like that.
Race 3 times and nearly the same result.

Race.1 From a stop all the way to 110mph and I was 1 1/2 car length ahead.

Race.2 From a stop all the way to 100mph and I was 1 car length ahead.

Race.3 From a 5mph roll and stop at 120mph and I was a car lenth ahead.

From a roll his 03 cobra is much faster. He even let me drive his car it felt pretty strong. Nice guy fun race.
 

· Registered
Joined
·
986 Posts
I have been through this same crap with Henry. He set my AVCR up the same way, and told me my car would not hold boost due to my hiflow cat. Bullshit, I re-did the install myself following MKIV, and viola, I can hold 1.3 almost to redline, before with "the Henry method" the car would not hold 1.05bar. Henry is a nice guy, but he is plain wrong on alot of things. Once, he charged me to remove all evidence of my BPU status, as I thought I had popped my motor(turns out it was my protectionist OBDII computer pulling timing due to a bad setting on my AFC), so I could take it to Toyota under warranty. Not only did he leave the TTC setup, the EGR disconnected, but he left the AVC/AFC harnesses in place! Toyota just laughed at me to say the least. Fortunately my car was O'k, and I did not need a new motor. Had I needed a motor, his work/lack of it would have cost me big bucks. I have since learned about the car, and do most of my own work, but Henry CERTAINLY does not know the correct way to set up an EBC on a MKIV twin. Ask Juhn about Henry, he will tell you a story of two years, and tens of thousands of dollars spent at a shop that cannot get a VPC to operate correctly. Anyway, I have not spoken to Henry since the last incident, he is a very nice guy, but he will never touch my MKIV again. I made ~335rwhp on his BPU install, redid it myself, and now I make ~385, go figure. Carl Byck
 
G

·
Discussion Starter · #31 ·
Yup Im gonna need to check everything again on my car myself.
Funny how he told me the same shit of not holding boost but it feels fine when I drive it. Im just gonna take it back to Bozz Performance this Friday and have them re-install my ebc the right way and double check the BCC and the S-AFC2. Hey Carl you can back me up on what I wrote down on the California Forum about anyone taking there car to MSD.

Oh yeah and for the RECORD guys there is no way in hell Im only making 294rwhp. 294rwhp is not enough to beat a 03 Cobra with light mods.;)
 
21 - 31 of 31 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top