Supra Forums banner
1 - 11 of 11 Posts
G

·
Discussion Starter · #1 ·
When I press the clutch in anywhere above about 2500 the rpms drop below 500 and wants to stall (rarly ever stalls). I have a totally stock 88T except for intake. What i want to know is why it does this and how can i fix it?

Thx for reading :)
 

·
No One Ever Listens To Me
Joined
·
6,005 Posts
did it start doing this after you put the intake on? make sure you connected all the afm electronics...as well as the all the hoses back.......

that is most likely the problem.....
 

·
No One Ever Listens To Me
Joined
·
6,005 Posts
still go and check all your electronics.....and also check ALL your IC piping....these are the two most relevant areas of inspection with this kind of problem....
 
G

·
Discussion Starter · #5 ·
A stock broken bov wouldn't do this would it? Im just wondering and i dont have a broken bov, or at least that i know of :(.
 

·
Your Neighborhood Pikey
Joined
·
3,480 Posts
Most people run into this problem when you run an aftermarket BOV that vents to atmosphere instead of back into the intake tract. In your case I would check all vacuum hoses and IC pipes. Last I would also check the deceleration dashpot for proper adjustment. If you're not sure on that one, check the TSRM that shows how to adjust it.

- Hams.
 

·
Registered
Joined
·
559 Posts
Supraboy86 said:
When I press the clutch in anywhere above about 2500 the rpms drop below 500 and wants to stall (rarly ever stalls). I have a totally stock 88T except for intake. What i want to know is why it does this and how can i fix it?

Mine does the same thing some times...but it always pops back up to normal. It has stalled a couple times. It could be a number of things but it is not bothersome enough to worry about.
 

·
Registered
Joined
·
28 Posts
I have the same problem today i checked the antifreeze lines from the isc they were dirty ran water thru em and took off the isc valve it was dirty too cleaned em n put it all back car idles good now but rpms still dropped again today when i put the car in nuetral after driving at high speed down to around 500 but bounced back up again and hasnt done it again since but its only been the first day so who knows but it definatley helped so try checking that first
 

·
Registered
Joined
·
1,178 Posts
I have the same problem today i checked the antifreeze lines from the isc they were dirty ran water thru em and took off the isc valve it was dirty too cleaned em n put it all back car idles good now but rpms still dropped again today when i put the car in nuetral after driving at high speed down to around 500 but bounced back up again and hasnt done it again since but its only been the first day so who knows but it definatley helped so try checking that first
not one form of punctuation in this paragraph
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top