Supra Forums banner

1 - 8 of 8 Posts

·
Premium Member
Joined
·
7,801 Posts
Discussion Starter #1
Ok so this car has the rps clutch and its acting really weird. When the car is at idle and you are giving it no gas at all...........you can put it in ANY gear (1-6) and take your foot off the clutch and it stays at idle.........you can even give it a little gas and take the rpms up to 2500 before the car even feels like it is moving at all and dies. When driving around at 3500 rpms it makes a really weird clattering noise as well. When you are taking off from a stop you have to rev it to 5000rpms or so before the car will actually move forward and as soon as it starts moving it all of a sudden will grab very hard. When cruising at 65mph in 6th gear normally if you take your foot off the gas the rpms will slowly start to drop..........in this case the rpms drop suddenly all the way down to idle(1100rpms)

In terms of driving WOT that seems to be the same as it always has.

I'm not sure what the problem is, I have heard it could be the tranny...........I'm hoping its not but what are your feelings on this?
 

·
Registered
Joined
·
1,212 Posts
hmm i have the same clutch. That does sound weird. I would say its prolly time for a rebuild on it. Sounds worn out. Better call RPS monday. On a side note does your clutch squeal?
 

·
T88 YOU
Joined
·
3,567 Posts
so when you put in gear and take your foot off the clutch the car does not move at all? does it feel like the clutch is not engaging or can you feel it try to engage and is just slipping?
 

·
Premium Member
Joined
·
7,801 Posts
Discussion Starter #8
the car does not move at all when idling.............it does not feel like the clutch is engaging at all...........i didn't notice it feel like it was just slipping...........i would imagine if it was slipping the car would at least move a little wouldn't it?
 
1 - 8 of 8 Posts
Top