Supra Forums banner

1 - 16 of 16 Posts

·
Registered
Joined
·
47 Posts
Discussion Starter #1
hey guys. i have a 94 na. i need some help with the s-afc 2. i recently installed them according to MKIV.com and Supra SONIC's safc install instruction. everything is spliced in correctly i believe. i have checked over and over again with diagrams and instructions just to make sure things are running right. here are the problems:

1) open stating up in the morning, my car's idle jumps up and down like crazy. it would jump from 1000 rpm to 600 rpm (sometimes less) and then jump up to almost 1500 rpms.

2) while driving and at complete stop, when i start to go the engine seems to almost die. yes guys i do know how to drive stick so its not like i'm stalling or whatever. the engine sometimes just seems like its gonna die and then i giv it more gas and then its cool. also when i'm driving and after shifting the samething occurs after shifting.

someone please help me out. i'm gonna go check everything out again now. thanks guys.
 

·
Registered
Joined
·
479 Posts
first thing I would do is clear all settings on the Safc.. then turn key off and go back and make all your new changes.. turn key off and go back to check if they are still the same..

oh, also check to make sure you got the throttle voltage setup correct..
 

·
Registered
Joined
·
1,225 Posts
sounds like you are either running too much fuel or your maf isn;t spliced in correctly... yah make surey ou are running karmen
 

·
Registered
Joined
·
47 Posts
Discussion Starter #5
hey guys. thanx for the quick replies. the s-afc is setup using the karmen wires. i have double checked all the wires and they are splicced in correctly. my car actually stalled earlier so i just went ahead and disconnected the s-afc for now till i find a solution.

the pink and orange wire are spliced into the same wire correct? and besides the ground wire, are these the only wires that splice into the same wire?
 

·
Now...Whitesupra94
Joined
·
3,284 Posts
TS94Supra said:
hey guys. i have a 94 na. i need some help with the s-afc 2. i recently installed them according to MKIV.com and Supra SONIC's safc install instruction. everything is spliced in correctly i believe. i have checked over and over again with diagrams and instructions just to make sure things are running right. here are the problems:

1) open stating up in the morning, my car's idle jumps up and down like crazy. it would jump from 1000 rpm to 600 rpm (sometimes less) and then jump up to almost 1500 rpms.

2) the engine sometimes just seems like its gonna die and then i giv it more gas and then its cool.
someone please help me out. i'm gonna go check everything out again now. thanks guys.
i have the safc one...the same thing happens to me....every time im in the staging lane next to a big v8 with straight pipes....didint think it was my SAFC, but i dont know what it is...maybe one of the wires isnt making complete contact
 

·
Registered
Joined
·
47 Posts
Discussion Starter #7
ok everyone is saying wiring so i'mma try to re-wire with new splicers and see what happens. thanks you guys. i'll let you know how this turns out.
 
S

·
Guest
Joined
·
0 Posts
TS94Supra said:
my car actually stalled earlier so i just went ahead and disconnected the s-afc for now till i find a solution.
what did you mean by disconnecting the S-AFC?

from the ECU or from the connecting wire (wire connected to S-AFC to be connected to wires on the ECU)... if the latter your engine won't rev above 2500rpm or something like that cos the voltage won't read right and the ECU will think there is no airflow or pressure....
 

·
Registered
Joined
·
47 Posts
Discussion Starter #10
SupraChigga03 said:
what did you mean by disconnecting the S-AFC?

from the ECU or from the connecting wire (wire connected to S-AFC to be connected to wires on the ECU)... if the latter your engine won't rev above 2500rpm or something like that cos the voltage won't read right and the ECU will think there is no airflow or pressure....
oooo damn... thanks for letting me know. i reconnected the wires earlier cuzz i had to go buy some stuff. i'mma check th wires tomarrow and solder them after double checking and making sure i have connected each wire to the right wire. thanks again.
 

·
Now...Whitesupra94
Joined
·
3,284 Posts
TS94Supra said:
oooo damn... thanks for letting me know. i reconnected the wires earlier cuzz i had to go buy some stuff. i'mma check th wires tomarrow and solder them after double checking and making sure i have connected each wire to the right wire. thanks again.
let me know the results, im curious...im sick of having to shut my car off in the staging lanes when the nasty sounding cars go by
 
S

·
Guest
Joined
·
0 Posts
TS94Supra said:
oooo damn... thanks for letting me know. i reconnected the wires earlier cuzz i had to go buy some stuff. i'mma check th wires tomarrow and solder them after double checking and making sure i have connected each wire to the right wire. thanks again.

ahh i see you read my post in time :) just clear the fuel correction maps and you should be running on stock fuel map - that is if you are still on the modified map (just record the modded fuel map corrections before you clear it just in case)
 

·
Registered
Joined
·
47 Posts
Discussion Starter #15
all fixed

thanks guys. car is fine now. turns out the smart guy who installed the s-afc for me did not cut the karmen wire so that one wire went in and one went out. i was pretty mad to find this problem. but the car is fine now. no more idling problems. no more stalls. now i have to go get this baby dyno tuned.

should i have this tuned immediatly or shall i wait for the cams then tune?

again thanks for all the help guys.
 

·
Now...Whitesupra94
Joined
·
3,284 Posts
cams or cam gears? either way, if theyre on the way, might as well wait. a word of advice dont make a sharp drop in the A/F ratio dont go from 14.5-13 in one tune point. try making the curve slight at first, like at 3500 and 4000 do a minor adjustment and get to you target A/F by 4500
 
1 - 16 of 16 Posts
Top