Supra Forums banner
1 - 10 of 10 Posts

·
Toyota/Lexus Owner
Joined
·
410 Posts
Discussion Starter · #1 ·
I have never had this problem with my car until today. It seems like I have a vacuum leak somewhere. A couple of days ago I could let off the gas or when changing gears and hear the BOV. It's a Blitz so it's pretty LOUD. Now I let off the gas or change gears and can't hear anything. The car is on and I could hear air inside the vacuum line to the BOV. If I pinch the line with my fingers, the air noise stops. Can anyone of you verify if there is supposed to be a audible amount of air inside the BOV vacuum line?
 

·
Republican
Joined
·
8,421 Posts
AFFERMATIVE!
 

·
2/3 HP to the Paws
Joined
·
1,519 Posts
I've never owned a blitz BOV, so I can't say for sure, but you shouldn't hear any air actively flowing through the BOV vacuum line when at idle.

Unless of course, the BOV is borked.
 

·
Toyota/Lexus Owner
Joined
·
410 Posts
Discussion Starter · #5 ·
and by borked you mean....broken, needs to be cleaned inside, lubed up, stuck? This is driving me nuts!!
 

·
Registered
Joined
·
523 Posts
thats what i was gonna say, but i dun have any experience with the aftermarket BOV's. obviously there is something broken if you "hear" air. get a vacuum gauge and see if the vacuum fluctuates at all. if you got time take the BOV apart and clean it up a skotch.
 

·
Akai Suisei - 赤い彗星
Joined
·
10,399 Posts
What should the normal vac read. My autometer is reading about 20
 

·
Registered
Joined
·
523 Posts
Here is what i found in a quick search on the net. The vac. gauge I got had similiar stuff in a little booklet. overall it seems like a damn easy way to check shit out. :bigthumb:
 

·
Toyota/Lexus Owner
Joined
·
410 Posts
Discussion Starter · #9 ·
Ever since I installed the Boost guage its read 10 vac. But the BOV would work regardless how much vac I had, now it wont work. I have the stocker in place as well as the Blitz, could the stocker have gone bad and it's tripping the Blitz out?
 

·
Tampa Bay Supras
Joined
·
707 Posts
My Autometer Boost/Vaccum gauge reads 20-23 at idle and I'm pretty stock as far as performance goes... Look at all the vaccum hoses, I have one that likes to detach itself every 2 weeks or so.
 
1 - 10 of 10 Posts
Top