Supra Forums banner
1 - 13 of 13 Posts

· Registered
Joined
·
547 Posts
Discussion Starter · #1 ·
i got my wiring issue fixed, so the car is running and drives, but its not making any power... i can hear the turbo spool, but the car drives like an n/a... why would it not be making any boost?? all of the exhaust from the header to turbo and wastegate are tight, and there are no boost leaks in the intercooler piping... my only other guess might be if the vaccum lines are set up right? i'm not sure... it's a gt30r turbo, china manifold, and hks look-a-like 50mm wastegate. right now i have the side vaccum line on the wg connected to the front of the turbo, and the top wg line going nowhere. help me figure this out!
 

· Not so boring anymore
Joined
·
7,936 Posts
ic pipe or wg stuck open.. im asuming open wg so you'd hear that..

lol a couple times my pipe fell off.. the 1jz sounds kinda mean na.. lol
 

· JZA is best f**k the rest
Joined
·
354 Posts
It is likely ur wastegate could be stuck. Just for kicks pull that intake tube off and make sure you didnt blow the turbo. This happend to me, my feed line was blocked off, you could not tell the turbo had blown, only that the car made no boost. I looked everything over and the last thing I checked was the turbo, I hope you have better luck than I did.
 

· Registered
Joined
·
547 Posts
Discussion Starter · #7 ·
how would i check if the wastegate was stuck open or if the turbo was blown. right now i have no intake pipe or filter before the turbo inlet. but i can see the turbo spin... and i know it's getting oil.
 

· JZA is best f**k the rest
Joined
·
354 Posts
claytonio disastro said:
how would i check if the wastegate was stuck open or if the turbo was blown. right now i have no intake pipe or filter before the turbo inlet. but i can see the turbo spin... and i know it's getting oil.
If you can see the actual blades intact then all is well. Put some compressed air to the wastegate, mine was stuck and this freed it up and works fine now.
 

· Registered
Joined
·
547 Posts
Discussion Starter · #10 ·
toyotech01 said:
If you can see the actual blades intact then all is well. Put some compressed air to the wastegate, mine was stuck and this freed it up and works fine now.
i have an air compressor, but how would you put compressed air in the wastegate? explain please
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top