Supra Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1,368 Posts
Discussion Starter #1
just installed a new slave and master cylinder in my 97 six speed at first it works perfect but after a few times compressing the clutch it begins to click, audibly and physically felt. Sounds like it is coming from somewhere near or is the slave near the tranny. Any advise would be great, so far I've tried pulling it out and clearing it, and then putting it back in.
 

·
Registered
Joined
·
1,368 Posts
Discussion Starter #2
maybe if i put a little grease on the tip of the rod ??
 

·
Supraless member
Joined
·
317 Posts
Mine does something like that too, but very randomly, and it does it when the engine and tranny are cold, on cold and wet weather only. Go figure^^.
On mine, it does one clear clicking sound at the exact moment of the pedal reaching its maximum travel point, and it sounds a bit like clapping two coins together. It disappears once the car gets warm.
Is is the same symptom you have? I could never find out what it was, my clutch (stock) and bearings are good. Then I got my clutch fluid replaced and I haven't heard it in a while. I have no idea if there is a relation or not. But the clutch is working fine, no clutch fluid leak whatsoever so I am not too worried about it.
94 6spd btw.
 

·
Registered
Joined
·
1,368 Posts
Discussion Starter #4
the first time it did the "click it was only one solid click just like you described but then we took it out and looked at it everything seemed normal so back in it went and now it is more like three small clicks. but tommoro the little bastard is comming out and i am going to put a little white grease on the tip i will report my findings..
 
1 - 4 of 4 Posts
Top