Supra Forums banner

1 - 17 of 17 Posts

·
Registered
Joined
·
134 Posts
Discussion Starter #1
I am thinking I blew my turbo once more. Driving and boosting everything is okay. Once I park somewhere and let turbo timer run down I get a bad idle and hella smoke screen, it is not white it is more of a bluish gray tinted smoke. Quite thick actually. Everyone else agree that turbo is gone or could it be something else. I am running Mobil 1 15w 50 motor oil.


Thanks,
Julian
 

·
Mr. 2JZUL8R
Joined
·
6,024 Posts
u get all that smoke at idle and turbo cool down?! :wtf: how much u get when u start her up on a cold morning? could be the turbo or the valve seals! pull the turbo and check for wasetgate crax or shaft play! :(
 

·
Registered
Joined
·
134 Posts
Discussion Starter #3
yes it smokes at idle when I come home from a drive. Cold mornings do not happen in TX, but it steams on the past few cool days. When it smokes and I rev motor it blows alot of smoke and then kinda pops. Turbochargers.com did repair on 8-13-03 so I ma thinkign they will eat this one and give me another one.

Julian
 

·
Registered
Joined
·
134 Posts
Discussion Starter #6
I think I may talk to Tommy (owner) and see about getting TO4E. If I give him the Ct-26 upgrade and pay like 200 bucks.

I hope that is all it is.

We will definately find out soon.
Julian
 

·
Registered
Joined
·
269 Posts
SupraNick said:
u get all that smoke at idle and turbo cool down?! :wtf: how much u get when u start her up on a cold morning?(
My car does the grayish smoke on cold mornings, and my valve covers are leaking hardcore, is that what you meant?
 

·
Registered
Joined
·
134 Posts
Discussion Starter #8
I fired her up today after letting it rest for the better part of yesterday. No smoke what so ever. WTF???

I am open to ideas to begin checking for.

Julian
 

·
Registered
Joined
·
134 Posts
Discussion Starter #10
K&N Air Filter, but I noticed some oil on the inside of turbo housing. Shaft play was minimal side to side and front to back there was absolutely none. Thinking the intercooler brought some oil into it. Anyone have a Catch Can for sale cheap?


Julian
 

·
Registered
Joined
·
134 Posts
Discussion Starter #11
Oil is still sitting on lip of turbo, smoke out the ass today. I am kinda thinking valve stem seals possibly??? Also I removed water lines from turbo since I could kinda smell coolant, no luck. Tomorrow I am going to do a Compression test and see how that comes out. What kind of numbers should I be looking for and what temp of motor should I do. Cold or after driving for awhile do the test?? How hard is it to replace piston rings if they are what is causing my mosquito truck effect?


Thanks,
Julian
 

·
Moderator/Troll Slayer
Joined
·
5,894 Posts
Oil might be part you problem... but lets look past that. What fuel system are you running..... is it aftermarket (IE. AFC?) If so does it smoke when its cold and when its hot? If it only smokes when its cold its due to you cold start injector..... the AFC doesnt care that the motor is cold or hot.... it pumps fuel from first start..... as well as the cold start injector. Try adjusting your fuel management system at idle a little more... take some fuel out of your afc ect. The blueish tint can not only mean oil but most of the time it means fuel also. Smell it.... put your finger in line of the exaust pipe when its running... smell your finger. Hope this helps at least someone.


Trey
 

·
Registered
Joined
·
134 Posts
Discussion Starter #15
no fuel setup yet, I am awaiting your AFC trey. Maybe I will pull my intercooler and clean it out along with the pipes and see what that does. What about maybe the hose running from valve covers to the accordian hose. Many different things I need to acount for. Maybe turbochargers will allow me to get a TO4E for price of my upgraded CT-26?

Who knows...

Julian
 

·
Registered
Joined
·
134 Posts
Discussion Starter #16
Problem solved, diagnosed and now preparing for rebuild. BHG #2 I am looking for a metal HG if anyone has one for sale. Thanks,


Julian
 

·
Registered
Joined
·
134 Posts
Discussion Starter #17
I got alot of work done in about 2.5 hours. I removed hood for ease of wroking and other misc. shit. I pulled radiator out to clean and repaint. Also I will be pulling front bumper to remove intercooler to clean as well. Hopefully friday I will pull head off and send turbo out to turbochargers tuesday for freshening. I removed one valve cover to see what oil looked like and it had a little milky look to it, nothing serious as last time, so I think I may have caught it early. I will be sending head off to be checked for imperfections. Also I am thinking the Titan 1.4mm bead HG and tq it to 80ft lbs with ARP studs that I already have. What should I do as far as block deck surface??? Leave as is or somehow get it smoothed also?


Julian
 
1 - 17 of 17 Posts
Top