Supra Forums banner
1 - 6 of 6 Posts

·
Ex Mkiv TT Owner
Joined
·
137 Posts
Discussion Starter · #1 ·
Im getting just a little puff of smoke on startups after the car has been sitting for more then 8 hours. The exhaust also blows out a little oil. i have 98000 miles. Could this be the valve seals starting to go. is there any other things it could be? Thanks.
 

·
Registered
Joined
·
69 Posts
how long is it smoking for on start up, if for 10 sec or less than the seals may be in the beginning stages of failing, mine smoked for 30 sec straight before i decided to just turn my car off and it was from the valve stem seals. just seems to be a weak part on our cars, but costly replacement
 

·
Registered
Joined
·
285 Posts
same here, my supra is a weekend car and after parking for a while it smoked on startup. It ate a lil oil too after a few K miles. Anyhow, I got my valve stem seals changed, the old ones were torn up...and now my car is happy, it doesn't chew gum or need a patch.
 

·
Registered
Joined
·
658 Posts
I think they all smoke a little on start up after they ahve been sitting for a while. If you start getting smoke while stopping for a light or stop sign then it is time to do the seals. I notice the smoke a lot more when it is cold out and it could also be condensation burn off from the muffler.
 

·
Ex Mkiv TT Owner
Joined
·
137 Posts
Discussion Starter · #5 ·
it is just a little puff of smoke and only after 8 hours or more. Is there anything else that could cause that or should i just take it in and have it checked out?
 

·
Premium Member
Joined
·
5,382 Posts
Mine does this too :( I'm at 100k

How much did you pay to do the valvestem seal replacement and who did it for you?
 
1 - 6 of 6 Posts
Top