Supra Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
157 Posts
Discussion Starter #1
My car has been smoking quite alot lately. every 3 to 5 city blocks when i get off the gas coming to a stop that's when i see a huge white smoke coming out of my exhaust. when i start to accerate then the smoke is gone. after 3 to 5 blocks it smokes again.

i did a search on this problem but my question is have anyone had this problem before and what did they replace to fix this embarrasing problem? the whole bus stop was watching my car smoke at the lights.

my car is bpued, there's no loss of power. it seems the problem is getting worse. it's smoking more often.
 
C

·
Guest
Joined
·
0 Posts
Look under my post on Vlave stem seal replacements, its either that or your turbos, but do a compression test first to eliminate any drastic engine problems
 

·
Senior Member
Joined
·
1,522 Posts
supra178 said:
My car has been smoking quite alot lately. every 3 to 5 city blocks when i get off the gas coming to a stop that's when i see a huge white smoke coming out of my exhaust. when i start to accerate then the smoke is gone. after 3 to 5 blocks it smokes again.

i did a search on this problem but my question is have anyone had this problem before and what did they replace to fix this embarrasing problem? the whole bus stop was watching my car smoke at the lights.

my car is bpued, there's no loss of power. it seems the problem is getting worse. it's smoking more often.
==============================================
My car has the same problem. It never smoked at all untill I put in the downpipe. I know my turbos were old so I changed them out and put a single turbo on it and it still smokes. With 92k on the car I am almost positive that it is the valve guide seals. (hopefully not the piston rings) It's imbarrasing but I just deal with it.....it goes away sometimes and them it comes back. I am saving up for some new valve guide seals.

Troy
www.eastcoastsupraz.com
 

·
Registered
Joined
·
157 Posts
Discussion Starter #5
thanks for the input and i had reread your post chester. some people have blueish smoke and some have white smoke. some have white smoke at start up in the morning and some have white smoke coming to a stop.

I'm wondering if there's anyone out there that have the exact same problem as me? And what exactly did they fix? Everyone seems to know white=water or coolant and blue or black=oil, but who had fixed the problem on their car before?;)
 
1 - 6 of 6 Posts
Top