Supra Forums banner

1 - 19 of 19 Posts

·
way over budget
Joined
·
664 Posts
Discussion Starter #1
Theres footnotes at the bottom.

yesterday i was sure that today was going to be an exciting day. My car kept blowing the efi fuse after replacing the head and putting on a 60-1 turbo. we pulled the harness, fixed a bunch of exposed wires and put it back in and the car started again, but it was too late to try to make it work right. Today i started working and got it to the point where it was driveable, but under load at about 1/2 throttle it started missing really bad, tried new plugs and everything. i was driving with a friend after school tonight and what do i hear? RODKNOCK!!!! Dammit, this is the third fuckin time i've had rocknock in the last 10 months. I need that guys avatar from a while back that is just annoying as hell that flashes "I HATE SUPRAS" at you. I'm at the point where I don't know what to do with the car now because i love it so much, but it's such a bitch to me. End of rant now, i had to let it out.

Footnotes: got car working with new mods after a month of sitting, wouldn't work, then got rodknock (3rd time in 10 months). now angry
 

·
Registered
Joined
·
139 Posts
does your name have anything to do with it? jk wow that sucks.

my advice would be dont drive it anymore. see if you can lift the motor up a little bit pull the oil pan and rods and crank, and see how bad it is before you do something crazy like get rid of it. good luck
 

·
way over budget
Joined
·
664 Posts
Discussion Starter #4
it ran for a week and a half after the turbo swap, the turbo started smoking and the head ticked so i got the turbo and swapped the head with another i had that i knew was good. I'd been watching the oil pressure quite carefully ever since we first started it and it's been good the whole time. I'll probably pull the engine to check everything once i get my vw running. I'd hate to get rid of it, soo much time into it, and when it does work there is nothing in the world that puts a bigger smile on my face.
 
S

·
Guest
Joined
·
0 Posts
this may sound stupid but, Check your harmonic balancer/main pulley and make sure the bolt is a) present and b) tight.
 

·
Buddy thought I had a NA
Joined
·
2,463 Posts
lowbudgettarga said:
i know that's on there, i used it to turn the motor over when putting the head back on and lining up the timing belt.
ummm i bet you broke your key in your blancer or it's loose remmber it may sema tight but all the belts hold the blancher very tight

trust me if you car is in good shape and has low milage or just should nto knock at this point i whould deff look into this i sean it so many times

oh yae the noise it mkaes sounds just like a rod nock and the sound comes from teh same spt as well the lower end fo the motor

i whould look inot it
 

·
Buddy thought I had a NA
Joined
·
2,463 Posts
i bet you any thing it is that if you don't think it should have rod nock cause it's in good shape
 

·
Not ur jizz, not ur bizz
Joined
·
6,571 Posts
supraturbo1987 said:
It's a 7M....anything is possible with that friggin' motor. I had plenty of headaches with it for over 4 years. Just got the 1jz swao done myself and I LOVE IT.

Trev
anything is possible with ANY motor..just like anything is possible when you do band aid fixes and piece of shit quality rebuilds. 3 rod knocks in 10 months doesnt indicate the engine to blame..it says more about the "mechanic" whos working on the engine.

everyone like to point fingers to make themselves feel better...thats weak.
 

·
Matthew 6:33
Joined
·
887 Posts
I don't think its weak Johnny. The 7M is a good motor, but if there aren't inherent problems after being rebuilt, then why is there a sticky on rod knock under the FAQ section?
 

·
Registered
Joined
·
6,279 Posts
csnow said:
I don't think its weak Johnny. The 7M is a good motor, but if there aren't inherent problems after being rebuilt, then why is there a sticky on rod knock under the FAQ section?
it is called peoples own stupidity, arrogance, ignorance a combination of the three or all three is why. ;)

And as Johnny Said. If people don't do it right the first time> There is ALWAYS plenty of time to do it right again ;)
 

·
Registered
Joined
·
2,767 Posts
hey, i know what you're talking about. i've killed um 5 upgraded ct's in the past year, cracked 2 pistons, broke 2 r154s, 2 motors, and 2 clutches, one being a 6 puck, and cracked 2 subframes. i dont think the 7m is a bad motor, or the r154 is a bad transmission. its my driving, plus um, 20psi of boost everyday. gotta pay to play. the only thing thats a piece of shit out of all the stuff i broke were the upgraded ct's (they blow) i'm finally moving on to a much more solid turbo. but i still love my supra, and i'll always keep it around.
 

·
way over budget
Joined
·
664 Posts
Discussion Starter #17
the first 2 times i got knock were definately my fault, first one was on a trip to the bay area apparently i got an oil leak son the way and noticed it was low on oil when i got down there, i changed the oil and it started knocking about a month later. the second time is just plauin stupidity, we had just put an r154 on my na engine since the w58 lost 1st and 2nd, and when we started it we left the ratchet on the crank pulley, it smashed the waterpump, fucked a bunch of shit up. (i know, dumbest thing ever, flame away if you like). That's the reason the turbo engine got swapped in. It was drove for a week and a half and started smoking. we thought it was the hg, and since the head ticked really bad, we put a new head on also, as well as the upgraded turbo. only drove it 24 miles after that before it started making the knock sound. hopefully it is the crank key, I honestly dont' think it should be knocking.
 

·
Registered
Joined
·
542 Posts
Definitly check that crank key and the pulley bolt. I thought I had rod knock and replaced all my rod bearings with the engine in the car only to find out all I had to do was tighten down the crank pulley bolt. But then I cracked off the bolt in the crank and had to get a new engine so I still got fucked in the end :D
 

·
Registered
Joined
·
2,767 Posts
i'm thankful to have never done that to the crank pulley bolt. i've removed it and installed it quite a few times. also, rodknock is another thing i've never had, i check my oil all the time and change it about every month or so. even when a hole got punched into my oil pan and all the oil came out... the motor was still okay, even the turbo was too. i drove it maybe 300yds with that hole, hahaha, that was a shitty day. i still tore the motor down and rebuilt it. now, i'm reaching the limits of the stock 7m pistons. i keep cracking the ring lands on the intake side. time for another teardown when i get the money for good pistons.
 
1 - 19 of 19 Posts
Top