Supra Forums banner
1 - 12 of 12 Posts

·
Sexy Bitch
Joined
·
392 Posts
Discussion Starter · #1 ·
Thanks in advance for any helpful reply's...

Here is the problem. When I start up the supra, my BRAKE light, Battery Light and the indicator light that tells you when you have a tail light out are lit. They stay lit for about 10-15 min of driving or less. Sometimes the lights will go out and then when i pull up to a stop light, they will come back on again.

Has anyone ever experianced this before?
 

·
Destroyer of Turbos
Joined
·
4,461 Posts
check to see if you have a tail light out. it might just be the high beam side of things.
 

·
Sexy Bitch
Joined
·
392 Posts
Discussion Starter · #3 ·
Thats not it... I checked already, and usually it only lights up 1 light, not all three.
 

·
Registered
Joined
·
184 Posts
My supra lite up the brake and battery light for a short time on start up prior to the alternator going out, have heard of several others doing the same
 

·
Madd Tyte JDM yo ®
Joined
·
7,014 Posts
the alternator isnt charging. fix it.
 

·
1.5JZ Turbo Supra
Joined
·
3,378 Posts
Test the battery and alt. Should be the fix.
 

·
Registered
Joined
·
375 Posts
i jsut had this problem, i thought i might of had the wrong blkub in there which i did, then i put the correct one in there and reversed the two filaments so they stayed lit the whole time, just make sure its the right bulb and its not backwards, check to makesure there isnt any corrosion
 

·
DDDDUUUUUBBBBBZZZZZZZZ
Joined
·
2,022 Posts
standard sign of dying alternator...usually they manifest themselves when the car heats up though. Test the voltage with the car on and off, see what you come up with and get back.
 

·
92 TURBO
Joined
·
1,009 Posts
havocatl said:
Thanks in advance for any helpful reply's...

Here is the problem. When I start up the supra, my BRAKE light, Battery Light and the indicator light that tells you when you have a tail light out are lit. They stay lit for about 10-15 min of driving or less. Sometimes the lights will go out and then when i pull up to a stop light, they will come back on again.

Has anyone ever experianced this before?

^ Sounds like you might have a shorted (grounded) diode in the rectifier inside the back of your alternator causing a "backfeed" up the Yellow with green stripe wire which is allowing the 3 different warning lights to get a negative feed. The 6 diodes inside the alt. block the flow of current in 1 direction which changes the AC to DC.
Disconnect the 3 wire connector from the back of the alt. to confirm this is the problem.
 

·
Missing my supra
Joined
·
629 Posts
glntom said:
My supra lite up the brake and battery light for a short time on start up prior to the alternator going out, have heard of several others doing the same

I'm with you on that... I had the same issues before my alternator shit the bed.
 

·
Sexy Bitch
Joined
·
392 Posts
Discussion Starter · #12 ·
Thanks for all the reply's. I just replaced my alternator and that fixed the issue.

SUPRAFORUMS RULEZ!!!!!!!!! :bigthumb:
 
1 - 12 of 12 Posts
Top