Supra Forums banner

1 - 18 of 18 Posts

·
Registered
Joined
·
63 Posts
Discussion Starter #1
hi all,just finished installed my bg kit last month.somehow i just can't boost more than 0.5 bar.checked all the vaccum hose,connector and seems fine.i found out my turbo is not spinning when car is ideling.if i gave it some revs then it will spin,will stop again if left idel.is this normal?im affraid i have a bad turbo..thanks for any help.
 

·
Registered
Joined
·
13,581 Posts
That's normal; turbos will not spin without loading the engine and at idle there is almost no load. I'd suggest looking elsewhere for low boost problem. If you have no leaks, check the wastegate setting.
 
L

·
Guest
Joined
·
0 Posts
Did you prime the oil in line on the turbo when you finished the install, that may have caused the turbo to spin dry usualy a bad thing

just one thing i thought of
luke
 

·
Registered
Joined
·
63 Posts
Discussion Starter #5
thanks guys.yes i did prime some oil to the turbo before start the car,when i spin it it looks fine and no shaft play(need double check on that)anyway,i found a loost vacuum line under the intake manifold.hope that's the cause.is late now i'll try run my car tomrrow.
 

·
Registered
Joined
·
190 Posts
Nick 95 6sp said:
That's normal; turbos will not spin without loading the engine and at idle there is almost no load. I'd suggest looking elsewhere for low boost problem. If you have no leaks, check the wastegate setting.
My turbo spins at idle. Maybe what you're thinking is turbos will not build positive boost without load?
 
S

·
Guest
Joined
·
0 Posts
it's normal for a standard bearing turbo not to spin at idle.

what are you using for boost control?
what is the wg spring pressure?
 

·
LEADED FUEL ONLY
Joined
·
2,068 Posts
I have a single BB ts04 and it spins at idle. It spins slow enough to see the compressor blades.
 

·
Registered
Joined
·
13,581 Posts
OK, I stand corrected. BB turbos and maybe even others for other reasons can spin a bit ...I had the no boost thing in mind. I'm sure if the exhaust gas velocity was kept high enough even at low flow because of header design and or exhaust housing design, it could spin a little at idle even with a non bb.
 

·
How does my exhaust smell
Joined
·
1,014 Posts
I have never had a turbo that did not spin at idle. I have had a PTE60, SP63, and SP67GTQ. They all spin rather fast at 850 rpms.
 

·
what will the future hold
Joined
·
916 Posts
I agree with the above comment! I have never had a turbo that didnt spool at idle. 57 trim, 60-1to4e, t61, and now t66

Will
 

·
Registered
Joined
·
312 Posts
try torquing the bolts on both sides of the cartridge in criss-cross
pattern applying about same torque to all bolts, i've seen on couple of turbos after you "clock" them to spin slightly or not spin at all; hope it helps, Rob NJ.
 

·
Getrag Gearhead
Joined
·
1,872 Posts
Shut off the car. Remove the intake and grab the compressor with your fingers and spin the turbo. The wheel should make a couple turns on its own with its inertial speed until it come to a stop. If its hard to turn then the unit may have been dropped during shipping. Not very common but you can't over rule the possibility. Any turbo I've seen spins when the engine runs and will not shut off until the engine is turned off.

Joe.
 

·
Registered
Joined
·
63 Posts
Discussion Starter #15
Thanks for all your helps.after i fix the leaking hose and change all plugs the turbo start spinning now.i'll check it few more time to be sure.car is running strong now.thanks again
Tan
 

·
Registered
Joined
·
108 Posts
I have a T78 it does not spin at idle ider, a small turbo shoul spin at idle.
 

·
I rock like CRACK
Joined
·
1,010 Posts
Any turbo BB or not is going to spin at idle, if it's not spinning something is def. wrong.
 
1 - 18 of 18 Posts
Top