Supra Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
302 Posts
Discussion Starter #1
Ok Since I bought my dawg I have not made a single tune up Awsome 3 yrs. I just became BPU and This weekend my car started to blu..blu..blu on low rpms. I'm suspecting spark plugs. If I stop, rpms go up and down a little bit. If I accelerate hard the car progreses slowly and the accelerates. After keeping it over 65 the problem seems to disappear for a couple of minutes and then appears again.....


Sugestions!!!!!

Thanks in advance!!!!


By the way the street car racing fever in Tampa is amazing I never seen so many street cars togetter...Guess who was turning heads !!! JEJEJE......
 

·
Super Moderator!!ON PATROL ALL OVER!!
Joined
·
10,459 Posts
um tune up????
 

·
Registered
Joined
·
302 Posts
Discussion Starter #3
Yea You know Spark Plugs!! gasoline filter..Air filter..Maybe an injectors clean up..or even the timming belt replace. Well I'm bringing it to a Toyota Service dealer to have it check.

What you think Ranger Sounds Like Spark plugs right!!!
Anything to worrie about :(

Thanks!!
 

·
Registered
Joined
·
54 Posts
Sounds like the plugs you put in may be too cold for your environment... They aren't staying hot enough to keep themselves clean....

In my opinion, 3330s are marginal for heat range, but if your making big power, they could be necessary.... BPU car most likely will not benefit from them....
 

·
Registered
Joined
·
302 Posts
Discussion Starter #5
Dammmmm $1400

Some leaks, the 60,000 miles work $400..Troatle cleanup and a lot of others stuff including new plugs ..that suck!!! an its a lot of money,,,,, well I can't be without my dawg

They are fuking me up for sure...

If there is a good Supra mecanic out there in tampa Please respond This will be the last time I bring it to Toyota services for sure Althought I expect the dawg come out withouth problems....

Hope:(
 
1 - 5 of 5 Posts
Top