Supra Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3,727 Posts
Discussion Starter #1 (Edited)
ok if you read my other thread then you would know that my clutch is messed up.
well i took it to the shop and he looked at it. he took both inspection plates off and looked at it. he called me and i went and he showed me.

My Spec Stage 3 clutch kit from jscspeed.com i had installed.
it worked for about 3 weeks just fine.

The guy at the shop told me that my clutch is engaged and isnt disengaging..WTF!!!

if you look at the pic the pressure plate spring things are pushed in and the shop said they are suppose to spring back out and they arent. i can wiggle my clutch fork around. he said me snap ring is ok and showed me that.



They said i need a NEW pressure plate cuz that ones fucked and i should ask them to pay for labor too.

WHAT should i do?? is this even possible? could it be something else?
can i buy a cheap stock one somewhere and it will work??! (plz say yes!)
should i call or email jscspeed.com and tell them WTF is up with this shit. will they replace it. without me sending the other one first? what should i say?

plz help me out.
 

·
Republican
Joined
·
8,421 Posts
thats how a supra pressure plate looks... it gets PULLED out when the clutch is disenguaging.....
 

·
Registered
Joined
·
2,649 Posts
CK is right, our clutch is a pull type clutch. Rather rare. Those splines should normally sit towards the engine, and they are pulled away from it when you push down on the clutch pedal.

There does seem to be something loose on the picture, though.
 

·
Registered
Joined
·
1,340 Posts
yea, the supra's are weird like that. we have a pull style setup.. what is the exact problem that your having?? that pressure plate looks fine to me.. also i have about 5000 miles on my spec stage 3 and she is working perfect. i beat the hell out of my car too. and i'm also running a sp61gt turbo as well..
 

·
Registered
Joined
·
3,727 Posts
Discussion Starter #5
i was wondering about that...cuz he said go look at your stock one and it will be pushed out, well i looked at it and its in.well shit. WTF could it be.
my slave cylinder is pushed all the way out and the clutch fork is all wobbly. and on the slave cylinder theres a bar that come out and pushes against the clutch fork and fits in a little hole/indention but it doesnt stay in that.
 

·
1JZ BLING!
Joined
·
2,747 Posts
Looks like one of your snap rings came loose.

I'd pull they tranny and inspect the rings. Unless the pressure plate straps broke, it's pretty hard for a pressure plate to fail. I doubt the pressure plate is bad.
 

·
Registered
Joined
·
3,727 Posts
Discussion Starter #7
i have about 1700 miles on mine.
i just called him and told him its a pull type. he said we will have to pull the tranny and see what the hell is wrong(would have to anyway)

well heres my other thread so everyone can read that, that hasnt.

http://supraforums.com/forum/showthread.php?t=276824
 
1 - 7 of 7 Posts
Top