Supra Forums banner

1 - 20 of 23 Posts

·
Registered
Joined
·
191 Posts
Discussion Starter #1
my speedo just stop working.. i check all conection but no luck...

a friend of mine has an extra spedo cable BUT its for an auto matic... wil it fit the r154 tranne aswhell?
 

·
Check Your Face!!!
Joined
·
1,417 Posts
break pretty easily, dude they last over 205,000 kms! the biggest problem is if they lose there internal lubricant, then they start whining and squeeking, then they snap.
 

·
Check Your Face!!!
Joined
·
1,417 Posts
the upper cables are the same, the a340 uses a 3 peice setup the first piece is the same as the first peice for the r154. the a340 uses 2 other pieces that are different, a intermediary cable and a adapter the goes into the back of the transmission. the r154 basically combines these peices into one cable. so long story short the upper cable is the same across both transmissions. they are the same, why because the part number is the same, 83710-14371 i believe, the second cable for a r154 manual is 83710-14800. the second cable for the a340 auto is 83710-14700 and the 3rd peice for the a340, the tranny adapter is 83770-22120. yes dealing with tranny cables is a bitch, and your local toyota dealership wants a 130-150 canadian for each one, YES! lol
 

·
No One Ever Listens To Me
Joined
·
5,467 Posts
yes they break...and break easily.... youre saying they dont because YO have ONE that hasnt? i know of about 4 people who have to replace them with right around or below 100k miles on the car...not to mention one i had to temporarily use and it snapped about 3 weeks later...

so i stand by what i said...they suck :D :p
 

·
Check Your Face!!!
Joined
·
1,417 Posts
yes fixing it is a bitch, im not going to try to change your personal history with these things, mechanical speedo cables always suck regardless, mine lasted 6+ months till it snapped after it starting making noise, so whatever. the question i was answer was the fact that the main cable for the r154 and a340 are the same cable, this is straight from toyota themselves, so whatever, i still stand by what i said, if it starts making noise its going to break soon which sucks.
 

·
TOO broke MK3
Joined
·
841 Posts
dam mine just snap while i was going up hill... i think the egr cooler leack also help out on this...

is there anyway to check which part i need to replace?
 
J

·
Guest
Joined
·
0 Posts
Dont mean to hijack the thread but...


When I get up to speed the needle bouces alot, it will show an accurate speed but bouncs alot getting to anywhere, do my cables need to be replaced, tightend or something along those lines? It doesnt make any sound either...
 

·
Check Your Face!!!
Joined
·
1,417 Posts
orion, just look at my previous post with all the part numbers, the upper cables are the same, which is normally what you need, on a A/T the tranmission adapter is prone to breaking after 200,000 kilometers.

joker, if your needle is bouncing, this is a early warning of a buggered speedo cable, listen carefully when you drive (stereo off) you may hear a faint squeeking that soon will turn into a annoying tortured rat sounding whine. the upper cable is normally to blame for this problem. the part number 83710-14371, which again, is the same for both the 5 speed supras and the auto supras. the lower segments are just different.
if you need one, ask in the champion toyota forum, they run about 70 US
 

·
Not ur jizz, not ur bizz
Joined
·
6,571 Posts
Jokerzinc said:
Dont mean to hijack the thread but...


When I get up to speed the needle bouces alot, it will show an accurate speed but bouncs alot getting to anywhere, do my cables need to be replaced, tightend or something along those lines? It doesnt make any sound either...
your car is suffering from parkinsons disease...Micheal J Fox and company are still looking for a cure..stay tuned.
 

·
Check Your Face!!!
Joined
·
1,417 Posts
ahh damn, all this time trying to get a new cable from toyota or off ebay, i should have been donating to stem cell research! DOH! :iwdumbass
 
J

·
Guest
Joined
·
0 Posts
Johnny Dangerously said:
your car is suffering from parkinsons disease...Micheal J Fox and company are still looking for a cure..stay tuned.


Why dont you :gtfo:
 

·
SupraStore.com
Joined
·
2,134 Posts
NecroCyde said:
orion, just look at my previous post with all the part numbers, the upper cables are the same, which is normally what you need, on a A/T the tranmission adapter is prone to breaking after 200,000 kilometers.
My 1988 car was originally auto but now manual. I'm assuming that doesnt matter then?
 

·
Not ur jizz, not ur bizz
Joined
·
6,571 Posts
Jokerzinc said:
Why dont you :gtfo:

lol wtf u gonna do about it, newbie? :stickpoke Hello, McFly..hello?!
 

·
Check Your Face!!!
Joined
·
1,417 Posts
thats right orion, it doesnt matter bugger with the upper cable, the lower cable will just have to be replaced from the small middle cable and adapter for the auto trans to the second cable for the r154 setup you have going. i believe the part number for that is 83710-14800.
 

·
Not ur jizz, not ur bizz
Joined
·
6,571 Posts
SupraMkiii24 said:
He's in Texas Johnny look out.

hey im down for a little confrontation action..we havea lot of Texas meets lined up this year!
 
1 - 20 of 23 Posts
Top