Supra Forums banner
1 - 9 of 9 Posts

· Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
I finally got my Supra running after being apart for 3 months. Everything is working like a champ except my speedometer is not working. Where is the speed sensor located so I can check the connection? If the connection is good is there a way to test the sensor? The car is a 87 turbo if that makes a difference. Also I want to get it on a dyno soon, what should that run?
 

· Supra Dead Head
Joined
·
620 Posts
whats is it doing? is the needle moving or it just sitting still ?

The speedometer is controlled by a 2 piece cable, a smaller section thats comes from the tranny connects to a longer cable that goes threw the firewall and into the dash.

you can get both from toyota the shoter one is like 30 bucks the longer is like 90

you can also test it by disconnecting the shorter cable and spinning the small needle thats inside with a drill hooked up to it, while spinning have somone tell you if the speedometer is moving or not.
 

· Registered
Joined
·
1,872 Posts
It could be the cable. I'd say check the shorter one first (between longer cable and transmission). Those snap sometimes, causing the needle to not move
 

· Registered
Joined
·
47 Posts
My 1988 long speedo cable is broken anyone know where I can buy one online? I don't have the time right now to visit a dealer.

Thanks.
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top