Supra Forums banner
1 - 6 of 6 Posts

·
I'll nevAr go single!
Joined
·
994 Posts
Discussion Starter · #1 ·
At 40Mph, acording to those radar things on the street, I'm doing like 33Mph or so.

I also notice that at say, 80Mph, it seems like I mite be doing 65-70 or so.

Now, when I bought the car I never drove it, so wether this is an old issue with it I do not know. Has stock sawblades and suspension on it, along with stock tire size all around.

Now here's where it gets ugly as to what could be causing this.

I have a '88 NA Sports Package with a LSD Diff. I am using the factory/stock Diff with a Turbo modle Driveshaft and a 1JZ w a R-154 from a '91.

I also lost the speedo cable for the trans and bought a new one, Part #83710-14800 .

So, thats it, I havnt read anywhere that a 1JZ swap would cause this problem, but also since I'm running stock diff and turbo DS and all that crap, could one or more of these be causing the problem, or could it be something completley different?
 
Joined
·
410 Posts
speedo is off because you change the gear ratio: i will have the same problem too i went from automatic to R154 so i have the A340E final gear the 4.30 LSD sportpackage and if im not mistaking if you have the 1JZ-GTE JZa70 R154 then your vin number should have said G299 which is the clutch 4.10 10 pinion gear rear end by the way dont buy them they are on ebay but when the clutch wears out then you cant replace them it sucks

so to correct this either put a 4.10 rear end in your supra (non jspec clutch) or you can put in the speedo drive gear from the tranny that came with your supra like the w58 or a340e or if it was turbo before put in the R154 speedo drive gear in the other tranny.

Myself i plan to go 3.90 for good gas milage kinda hard take off but i will keep my 4.30 for drag days anyways im set.
 

·
I'll nevAr go single!
Joined
·
994 Posts
Discussion Starter · #3 ·
Speedo drive gear, are you talking about the "Housing" or whatever it is, that the speedo cable plugs into on the tranny?

Oh and my tag under the hood is gone, so cant see the axle code. But I should have the 4.30 right? And the 1JZ's tag says G294, the 4.10 Torsen right?
 

·
going broke fast
Joined
·
2,401 Posts
you would have to change the gear in the tail end of your tranny.the jza70 4.10 rear is gear to gear lsd,no clutch packs.
 

·
Registered
Joined
·
1,480 Posts
You're on a 4.30 USDM LSD. From the differences you're seeing I'd say your tranny has the speedo drive gear for a 9.73 diff. Unfortunately, the W58's speedo drive gear has a larger diameter than that of the R154. You MIGHT be able to swap in the N/A's speedo gear, but I know the R154 drive gear won't work in a W58. Using a drive gear for a R154 with a 4.1 diff would put you much closer though.

EDIT: and yes, we are talking about the gear that's connected to the small housing the speedo cable connects to. When swapping remember to drain your tranny fluid first.
 

·
I'll nevAr go single!
Joined
·
994 Posts
Discussion Starter · #6 · (Edited)
Bah, scratch this post, found out the answer to my question.
 
1 - 6 of 6 Posts
Top