Supra Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
74 Posts
Discussion Starter · #1 ·
Well looks like the rough idle was caused by the broken intake manifold - to - air charge tank gasket, I fitted a fresh gasket, cleaned the ISC unit, re-adjusted the TPS and now it idles at 600 RPM like it should have done before the Metal head gasket install.

But...I'm getting a code 31 (air flow signal) whenever I deccelerate the car as the revs drop down towards idle speed, it would somtimes stall as it drops below 500 RPM.
 

·
Registered
Joined
·
74 Posts
Discussion Starter · #3 ·
It seems most likely to be the AFM electronics. The car can start up and idle at 500 - 600 fine, it's just when you apply gas and let go so the engine can drop to idle will it stall, the check engine light only appears when it drops at this speed.

I didnt know that the AFM could have a fault yet still part-function, looks like I will have to search around for a AFM black box somewhere.
 
G

·
did you pull the power cables? If you did the ecu reset and needs to relearn stuff. Drive around for a while and eventually it will fix itself.
 
G

·
Did you try checking the resistance across the last two electodes on the AFM? A list of acceptable ranges is listed in my "off-the-shelf manual" from the corner parts store. I'm sure you can locate these values online. If not I will send 'em to you.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top