Supra Forums banner

1 - 7 of 7 Posts
A

·
Guest
Joined
·
0 Posts
Discussion Starter #1
Everytime I crank my cold engine it just goes"CLICK",I then go back and crank again and it seems to make contact and start up.Sometimes it takes a few tries.I've replaced the battery and clutch start switch already. Any help would be appreciated. Another question: How much does the starter usually run and how hard is it to install? Thanks Alex 93tt 6spd hardtopper
 

·
Super Moderator!!ON PATROL ALL OVER!!
Joined
·
10,459 Posts
sounds like your starter is craping out ....dont know how much the items and labor sorry !
 
A

·
Guest
Joined
·
0 Posts
Discussion Starter #4
Yeah I was thinking it was the starter,,,man when it rains it pours!Thanks for the help!Alex 93 tt 6spd hardtopper
 

·
Registered
Joined
·
1,081 Posts
Alex,

It may just be the contacts not the actual starter..buy the contact kit and replace it. Do a search for "starter" or something since it was posted a few weeks ago..not sure..for like $20..much less than a new starter. Call Jay Marks Toyota and speak with Jeff...he should be able to give you the part number.

Shawn.
 
S

·
Guest
Joined
·
0 Posts
Discussion Starter #6
MY STARTER IS DOIN THE EXACT SAME THING. . .how hard is it to replace? . . how long did it take. . .. anyone?
 
S

·
Guest
Joined
·
0 Posts
Discussion Starter #7
HmoobSUPRA said:
Alex,

It may just be the contacts not the actual starter..buy the contact kit and replace it. Do a search for "starter" or something since it was posted a few weeks ago..not sure..for like $20..much less than a new starter. Call Jay Marks Toyota and speak with Jeff...he should be able to give you the part number.

Shawn.
. . .what do you mean. . ."Contacts" . . . .did anyone get a part number. . .if so can you post it?
 
1 - 7 of 7 Posts
Top