Supra Forums banner
1 - 17 of 17 Posts

·
Registered
Joined
·
2,332 Posts
Discussion Starter · #1 · (Edited)
ok i burped it really good last night i had the water shooting out when the thermo opened up so i quickly closed the cap while it was coming out to keep air from getting in. i only let the thermo open once. so when im driving its fine when there isnt a car in front of me. when there is it warms up a little but when im sitting still at a light or in traffic the needle does start to rise. the rad is 2 or 3 years old so i dont think its that. could the thermo, water pump, or rad cap cause it? or is there still trapped air???? idk what could be wrong and im pissed its trying to blow it self up again grrrrrrrrrrrrrrrr
 

·
Registered
Joined
·
300 Posts
what fans are you using? make sure the water pump is not clogged from all the residue in the cooling system. try running it w/o the thermostat to see if it still does it, make sure the radiator cap is good, otherwise it will leak the pressure causing the car to overheat. check the compression in the engine and look for unusual drop in compression, as if you have a cracked HG, it could be a cause as well.. there are many things you can check, but a process of elimination can help a lot.

good luck
 

·
Registered
Joined
·
300 Posts
also be sure to jack up the car in the front before you fill up the rad, the neck of the rad needs to be at the highest point and add coolant slowly so that air pockets can vent out...
 

·
Registered
Joined
·
361 Posts
i would try what degree said

i put a new t stat in from advanced auto
worked great for the past month
but now it sticks really bad when 1st driving
my autometer temp gauge will rise to 220 when i 1st drive
i then press my clutch in and rev it up
then it unsticks and goes back to 190 lol
after that it works great

replaced with toyota tstat and presto works awesome again
 

·
Registered
Joined
·
318 Posts
how old is the water pump? it could be the water pump seeping out which is a sign that it needs replacing. also check the hoses that are on the motor for any cracks or leaks as well as make sure all the clamps are tight
 

·
Registered
Joined
·
2,332 Posts
Discussion Starter · #11 ·
^ the water pump looks factory its just as dirty as the block and the car has 226xxx on it. Its also leaking from the bottom of the water pump. I found it late last night and ill be picking up a new one today
 

·
Banned
Joined
·
3,628 Posts
^ the water pump looks factory its just as dirty as the block and the car has 226xxx on it. Its also leaking from the bottom of the water pump. I found it late last night and ill be picking up a new one today
Do yourself a favor and get cooling system parts directly from Toyota.
 

·
Registered
Joined
·
2,332 Posts
Discussion Starter · #15 ·
Well the dealer can't get me the parts in time so I'm getting a life time warrenteed pump from auto zone only cause Ik it will fail but I will only trust oem Toyota thermostats but I can't get one in time since I have to leave to go back to Ohio Sunday night
 
1 - 17 of 17 Posts
Top