Supra Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
82 Posts
Discussion Starter · #1 ·
hey all

ive got a jdm 2j with usdm twins swapped in. running in ttc. they spool and boost with no problems.

the issue im having is that under heavy load the ssqv doesnt vent and one of the turbos is shooting air back out the intake. when you ease off the throttle at low rpm the bov functions properly, but any kind of heavy load and the bov is barely heard and just the smell of oily air shooting back down the intake pipe.

i have gone over the vacuum lines and they all seem to be in proper place and not leaking.

the car has a q45 tb, greddy intake mani, night pager twin intake, hks evc-s. the IAC is removed. some of the harness was deleted as there were alot of extra plugs.

it seems like something is closing behind one of the turbos with an abrubt throttle let-off and forcing the air back the other way. i am having a hard time diagnosing this one and any suggestions or help is much appreciated.
 

·
Registered
Joined
·
7,726 Posts
wait, how do you know that the BOV isnt functioning under high boost? are you hearing surge? why not put the stock bov on to ensure that it is that? i doubt that this is a bov problem, but your method of diagnosis is kind of confusing to me. also, what about your exhaust system, stock? upgraded? restrictor ring? cats? ect. post more on your symptoms and maybe a vid and we might be able to help you out more but there isnt enough information here, not for me anyhow.
 

·
Registered
Joined
·
82 Posts
Discussion Starter · #3 · (Edited)
im running open 3 inch exhaust through out, but i mentioned before that i have upgraded to the usdm twins, no need for restrictor ring.

this happens at high boost settings and low boost settings, there is a very hard surge when i abruptly let off the throttle not a typical compressor surge chatter.

i put the car back into sequential mode, and it seems that its only happening when the second turbo is online. i will have to verify that tomorrow.

ill work on getting a vid ..

the most apparent thing is the smell coming into the cabin when i make a hard pull then let off. it smells like the oil i run.

edit: p.s. sorry about the lacking original post :D
 
1 - 6 of 6 Posts
Top