Supra Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hello, I just started up my dad's mk3 that has been sitting for 10-15 years. My problem is that when idling, my rpms will drop down to 500-400 and then shoot up to 1500 or so and then it drops back down to 400 and does the same thing. Any help would be greatly appreciated!
 

·
Registered
1987 Toyota Supra
Joined
·
360 Posts
Could be all kinds of things.
Vaccum leaks, intake tract leaks, IACV sticky, shit fuel, clogged this that or everything.

Got any other information?

It's going to need a lot of attention if it's been sitting around that long.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Yes, I should have clarified some things:

1. The gas that I put in there is new- I cleaned out the old gas in the tank and replaced the fuel pump and filter
2. All of the vacuum hoses are where they are supposed to be- I will check for leaks
3. I replaced the spark plugs and starter
4. There are no leaks in the fuel lines

I will look into what you previously mentioned. I appreciate the help!
 

·
Registered
1987 Toyota Supra
Joined
·
360 Posts
If you are for certain no vaccum leaks are present and the AFM is measuring ALL airflow going into the engine. (No unmetered air)
I would start with removing and cleaning the IAC.
The actuator might be sticking.

Otherwise there are a host of other things that may cause this as well.

Does it cold vs hot? Or all the time?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
It's hard to say because last night was the first time it's started up, so I'm not sure if it would do that when it's warmed up. I didn't want to risk damaging anything so I turned it off when I noticed it was being strange
 
1 - 5 of 5 Posts
Top