Supra Forums banner

1 - 12 of 12 Posts

·
GIT-R-DONE YALL HEAR
Joined
·
491 Posts
Discussion Starter #1
Well, here is my roblem.

My supra Studders as soon as i step on the gas a little harder in any gar. What it does is kinda jerks back and forth, like there is a boost leak somewhere, or fel cut.. also alot of black smoke comes out of the exhaust when this happens... i checked to make sure there is not a boost leak and couldnt find any it dos this no matter engine hot or cold. it also takes a long time for it to accelerate. my car was running 450rwhp, then i blew up my turbo so now im running ct26 till new one comes in.... my car ws tuned for the sp61gt turbo and 18psi, now since im running 7psi might that be the problem. hopefully i explained my self so you can undestand the problem... what might it be...
oh by te way my SAFC is set to 0% accross the high and low throtle setting... i'm not running any boost controler, and dont have a fue ct defencer.

Please help
--nick
 

·
Registered
Joined
·
195 Posts
wow....what a small world. Hey nick this is Michael. Ring a bell? Ya i drove 800 miles to pick up your supra that you "blew the turbo on." Still having problems after 2.5 years huh? haha. I hope you never fix it.
 

·
Registered
Joined
·
195 Posts
Oh and i waited for you to call so you could bring me the car but hmmm....you never did. In fact, you would even return my calls. Serves you right.
 

·
GIT-R-DONE YALL HEAR
Joined
·
491 Posts
Discussion Starter #5
wow....what a small world. Hey nick this is Michael. Ring a bell? Ya i drove 800 miles to pick up your supra that you "blew the turbo on." Still having problems after 2.5 years huh? haha. I hope you never fix it.
Michael,
nice to see u on supraforums again, too bad its not the same supra that u wanted
--nick
 

·
Registered
Joined
·
195 Posts
Then u must be a moron, damn how many turbos you blow??? And i didnt want your pos anyway, the paint was awful, it wouldn't start, you had some flammer gauges in it, and oh ya...the kicker, i got a nicer and faster one. ON 21psi nick, i dynoed 505 and im runnin 24psi now. So in the end...THANK YOU.
:fawk:
 

·
Registered
Joined
·
3,877 Posts
where the fuck did this douchebag come from?

ever heard of PM's? good, now take this idiotic discussion there
 

·
Registered
Joined
·
195 Posts
Sorry man, i just had to get this off my chest, this guy screwed me hardcore on a car and i've tried to contact him many times, this was my oppertunity, so i took it.
 

·
BMM
Joined
·
2,329 Posts
:ugh2: SupraMOB- Use the PM system. It should keep you from getting baned... Emik87t- :gtfoslap: you started it.

Back to the original post... I'm assuming you have upgraded your fuel. I would take away some fuel if youre on the ct26. Then It sounds like you might just be rich. try it and post back.
 

·
GIT-R-DONE YALL HEAR
Joined
·
491 Posts
Discussion Starter #12
***BOOSTEDMKIII***
yes i do have the upgraded fuel system 550's and a walbro fuel pump, i ws running 42psi on the FPR i lowered it toabout 38 and still same problem
im afraid if i go any lowed imma get to lean and mess up the engine
any suggestions on whats safe on the FPR for a ct26
--nick
 
1 - 12 of 12 Posts
Top