Supra Forums banner
1 - 12 of 12 Posts

·
GIT-R-DONE YALL HEAR
Joined
·
491 Posts
Discussion Starter · #1 ·
ok guys here is my problem. whenever i turn my a/c, heater, or even lights on, my car looses power. the battery that i had on there was about 6 years old, so i got a new one, i thought that was the broblem, but still same thing. i checked my alternator, and it works. it feels like it looses electricity, i try to accelerate but no effect. i dont know if it is my fuel, electric, or intercooler going bad. i got stock intercooler and stock pipes on 17psi. thank you for your help
 

·
Registered
Joined
·
6,907 Posts
Haven't heard of that problem before. Perhaps the alternator is inefficient and is putting a large load on the engine to produce normal power? It seems far fetched though.

Have you checked your codes?
 

·
Registered
Joined
·
114 Posts
Check your grounds..if you've got good voltage and the alternator is putting out like its supposed to..Id be willing to be you're losing power through a ground somewhere..
 

·
No One Ever Listens To Me
Joined
·
5,467 Posts
yeah very true...if its hp then i would say check your afm and whatnot..but for electrical power grounds and all the wiring harness clips would be a key..... also FYI when you turn your AC on you lose power anyways...thats normal.....

and um for the record 17psi on stock IC and pipes? is this on stock turbo too? :nono: but thats a whole nother thread!
 
G

·
I'd be willing to bet that there is a ground somewhere that isn't getting good connection or just not connected. I just finished an automotive electrical class through college, and that was one of the things that my group had to fix, one of the other groups disconnected a bunch of ground wires that were all in the same place, and everything went dim. What I'm trying to get at is, check ALL grounds.
 

·
GIT-R-DONE YALL HEAR
Joined
·
491 Posts
Discussion Starter · #11 ·
ok sorry for not making my self clear, i loose electrical power, and i kknow when i turn my ac on i loose power, but not that much, it was good before, and also i do not have a sotck turbo 60-1. thanx
nick
 
1 - 12 of 12 Posts
Top