Supra Forums banner

61 - 80 of 83 Posts

·
NOSUP4U
Joined
·
2,776 Posts
Discussion Starter #61
4 months now :/ killing me man
 

·
NOSUP4U
Joined
·
2,776 Posts
Discussion Starter #64
Have you bought a new denso o2? I believe you need the 3 wire type for the aristo. Amazon.com FTW
Yea its got to be a 3-wire and also 2 bolt flange type which has proven to be very hard to find!

did you try messing with the safc?or removing it?
I have messed with the settings, tried karman, hotwire, and pressure, also unplugged it..but I have yet to remove it completely..I was thinking about doing that next!
 

·
Registered
Joined
·
738 Posts
a friend of mine blowed his engine with an safc because he didnt know what he was doing,another one run mega rich because he didnt know either.he ended up with so much carbon that it was hitting the valves.another one had a malfunctioning one that runned 3 cylinders lean and one rich making the af show ok..btw have you checked for a stuck injector?
 

·
NOSUP4U
Joined
·
2,776 Posts
Discussion Starter #66
yea, i plan on completely removing the SAFC and seeing how it runs. Also, I had he stock 440cc injectors in there initially and it did the same thing, then put the USDM 550cc's in and it still did it, so I ruled out stuck injector. Thanks for the help BTW!
 

·
NOSUP4U
Joined
·
2,776 Posts
Discussion Starter #68
thanks! I should be ordering one tomorrow! haha
 

·
NOSUP4U
Joined
·
2,776 Posts
Discussion Starter #70
single 255 walbro, been running it for 4 years now with no issues, had it on both my NA-T setups that made 400 and 450 whp...
 

·
Registered
Joined
·
501 Posts
ive seen some rx7s run super rich after they did a fuel pump mod or replaced their fuel pumps with a beefier pump. maybe something to double check
 

·
Registered
Joined
·
3,616 Posts
yea, i plan on completely removing the SAFC and seeing how it runs.
You still have the SAFC in there? That would have been the first thing I removed from the equation. Just put the two wires that alter the MAF signal back to stock so that the SAFC has no ability to alter the MAF or MAP reading.
 

·
NOSUP4U
Joined
·
2,776 Posts
Discussion Starter #73
Yea I feel kind of dumb for not doing it sooner but at this point I just want the car running. Hope it fixes it!!!
 

·
NOSUP4U
Joined
·
2,776 Posts
Discussion Starter #74
So removed SAFC and car runs ALOT better. codes are gone, it doesnt sound like shit, revs cleaner, and no more pure gas smell. Only 1 problem, its still idling at 11.0, but The o2 sensor and plugs are absolutely shot by now im sure, so going to change both of those along with the oil, and go drive it and see how she does! woohoo!
 

·
Registered
Joined
·
738 Posts
glad you are coming to a solution.btw 550s will still run a little rich on a jdm ecu but not at the 11s.somewhere on 13s maybe
 

·
Registered
Joined
·
2,028 Posts
Way to go buddy. I know you been frustrated and wanting to drive the car. I am glad you got it running again.
 

·
Raising the BAR
Joined
·
3,325 Posts
I have an Aristo TT swap and I have verified the ECUs SN to being a JDM ECU and I am also getting a code 31 for no MAF output and my car runs fine. The car does run super rich and smokes, but Im certain I have fried piston rings on a count of the overwhelming gas smell in my oil that I just freaking changed.
 

·
Hardtop Crew
Joined
·
6,377 Posts
same here^
 

·
Registered
Joined
·
11 Posts
^Any updates? I have similar issue Mine runs super rich when I first start it (IAC) is plugged because when its open it just sucks air and my idles way to high, I just feather the gas till its able to idle its 11ish A/F, as it warms up the A/F's are pretty good. Even after its warmed up randomly at a stop light I'' see it drop to 12 randomly. I also randomly get CEL after boosting.

Dont know if it relates to your issue, but update us if it fixed
 

·
Registered
Joined
·
196 Posts
If you guys are getting code 31 on a JDM car, it is MAP related. That is the first place I would look. Just like the OP ended up doing, if you have any kind of piggy back, get rid of it until you find your problem. Also, the OP is running larger than stock injectors so his idle is going to be a bit rich no matter what.
 
61 - 80 of 83 Posts
Top