Supra Forums banner

1 - 20 of 22 Posts

·
Registered
Joined
·
2,712 Posts
Discussion Starter #1
Just came back from Houston. I've been to a few Vegas meets but this was my first TX one. Things I noticed. Way more cars at Vegas, more show n shine, more people. But way more involvement in Houston. Everyone goes there to run. More people racing both at the drags and street.

We met at a huge shopping center parking lot at night. Cops showed up and told us to leave. Owner of the property showed up and kicked cops to the curb. Told us to stay as long as we like and told the cops to get lost. Lots of fast cars like turbo vipers, vettes, stangs and of couse supra fried rice. There was a twin turbo 434 cubed z06 that maxed out the dyno at 1200 hp at 5000 rpms. He lined up with one of our own and ran 3 times. There was also a 300 hp turbo busa it had a 60mm turbo on it. He also lined up with one of our own and ran twice. :p
 
R

·
Guest
Joined
·
0 Posts
cummins said:
There was a twin turbo 434 cubed z06 that maxed out the dyno at 1200 hp at 5000 rpms.

So I see RedC5 finally decided to dyno his car at full throttle

also so vegas is better than Texas?
I went to vegas but never TX, every year TX doesnt seem all that interesting
 

·
Registered
Joined
·
2,687 Posts
Vegas is easier to have fun in but the organization in TX due to Peter (and sponsor support) is just flat out WAY better.
 

·
I'm very humble.
Joined
·
1,399 Posts
cummins said:
Just came back from Houston. I've been to a few Vegas meets but this was my first TX one. Things I noticed. Way more cars at Vegas, more show n shine, more people. But way more involvement in Houston. Everyone goes there to run. More people racing both at the drags and street.

We met at a huge shopping center parking lot at night. Cops showed up and told us to leave. Owner of the property showed up and kicked cops to the curb. Told us to stay as long as we like and told the cops to get lost. Lots of fast cars like turbo vipers, vettes, stangs and of couse supra fried rice. There was a twin turbo 434 cubed z06 that maxed out the dyno at 1200 hp at 5000 rpms. He lined up with one of our own and ran 3 times. There was also a 300 hp turbo busa it had a 60mm turbo on it. He also lined up with one of our own and ran twice. :p
Were there multiple dyno events? Cause here are the results of this year..
http://supraforums.com/forum/showthread.php?s=&threadid=267510

You get any of the racing on video? Any pics? I'm going to try to make next year but Vegas for sure!!
 

·
Registered
Joined
·
2,712 Posts
Discussion Starter #9
No just that dyno event. The vette did those numbers before TX. Didn't get any pics or video. I was supposed to line up with the supra and vette but some idiot (guy in a supra) parked his car in my lane to watch the race. We all flashed him the beams but the guy just sat there. DOH! So the vette and supra raced and I got cock blocked.
 

·
Moderator, Aight Peace
Joined
·
6,130 Posts
Well, VEGAS for sure... next year TX, cummins, did ya fly to TX or drive?? aight peace :chicken:
 
5

·
Guest
Joined
·
0 Posts
Patrick, good to here you made it back safe. I thought Las Vegas was a long drive!



:)
 

·
Registered
Joined
·
2,712 Posts
Discussion Starter #12
I drove there and trailered the rice. It was about a 2000 mile drive one way. Ughhhh.

Louis hit me up I got you a shirt.
 

·
Registered
Joined
·
2,712 Posts
Discussion Starter #15
Was a fun but frustrating trip. Got there the first night and was going to do some street races but the car ran like shit. Changed the plugs the next morning and all is good. Next night did some runs with other supras. Was going to race that 1200 vette but got cock blocked. Instead raced another supra. But since its not on video it never happened.

Went to the drags the next morning. Tried to run but the car wouldn't boost past 1 bar and was very slow to reach it. Hit 1 bar at 6500 rpms. Looked for boost leaks and didn't find any. During a run I blew a hole in an ic coupling. Ran around trying to find another one. Finally did. Went for another run and one of the walbros died before the 1/8th. Ran around trying to find a walbro but no luck. By this time its 5 pm so I just parked the car and watched the finals.

I'm running dual Walbros and this is the 2nd pump that died in less than 2k miles. I'm dumping the whole system system and going domestic style. I checked the compression and all is good. I heard that walbros dying cost a few other supra peeps a motor so I guess I'm lucky there.
 

·
Registered
Joined
·
1,338 Posts
Damn this is making me worried. I'm running dual walbros as well. I guess after the engine build up, I'll get john to do some fail safe with the aem just to be safe.
 

·
awz.
Joined
·
452 Posts
Thats the one.

Must have been scary as shit, having it let go at high speed like that.

Not to mention the dude on the bike behind him, who pretty much went triple digits into a wall of smoke. Talk about pucker factor.
 

·
Registered
Joined
·
2,712 Posts
Discussion Starter #20
Mine went out during high boost at wot. I noticed it right away and got out of it. I guess I got out of it in time my motor is ok. I know of 3 others that had walbros fail costing them motors. Fuck walbros. I wouldn't even do the aem fail safe. Why run junk. I'm looking into other systems now.
 
1 - 20 of 22 Posts
Top