Supra Forums banner

1 - 6 of 6 Posts

·
Supra Enthusiast
Joined
·
2,382 Posts
Discussion Starter #1
I'm having a bad surging problem once the car gets up to normal opperating temps. When I come to a red light or just stop, my idles raises to about 1k, then falls down to about 700. It just continues to surge. Now, I'm pretty sure that the problem isn't the Map ECU, but the reason why I even mentioned MAP was because I eliminated my AFM and the accordian hose. Since I don't have the hose anymore, I don't have any way to connect the hose from the IAC to the front of the turbo. I just have a filter on the compressor housing. Is the problem the IAC getting too much air due to there fact that I elimitated the hose?

I'll post a pic in a few just so I can better explain.
 

·
Supra Enthusiast
Joined
·
2,382 Posts
Discussion Starter #3


You can see the black hose that I have rigged coming from the IAC going acrossed the valve covers
 

·
Premium Member
Joined
·
5,301 Posts
With the map setup, you only need a filter right on the ISC valve. Just get a little K&N and put it right there on the part of the ISC that the hose would normally attach to.

TPS, ISC, or the MAP ECU could all be sources of the problem.
 

·
Supra Enthusiast
Joined
·
2,382 Posts
Discussion Starter #5
I'll try the breather. Thanks Trent. As far as the problem coming from Map, any ideas on that? I checked the tps and to MY knowledge it tested fine. I also checked that it was reading the right signal from the dashboard screen on map.
 
1 - 6 of 6 Posts
Top