Supra Forums banner
1 - 10 of 10 Posts

·
Registered
Joined
·
453 Posts
Discussion Starter · #1 ·
Sorry to everyone about making another post about this but my feedback completely died. Before at BPU in TTC the car would start to spin the tires at the end of 2nd gear. Now with 15 lbs on my t78 it wont do that AT ALL. Pulls hard and all though....Just wont break tires lose anymore. 1st to 2nd isnt even alot of spinning. Has anyone else had this issue?
 

·
ƒ=1/2π(√k/m)
Joined
·
10,130 Posts
When I upgraded to a larger t4 turbo, I didn't get wheel spin either.

It's a linear boost curve due to the spool characteristics.... the vehicle is in more motion.

At least that's what I think is going on.... could be clutch issues too :)
 

·
Supra Owner Since 1996
Joined
·
2,715 Posts
You don't have a butt dyno?
 

·
Registered
Joined
·
1,539 Posts
BPU will have much more torque earlier down low so this is not surprising. Go to the track or grab a Gtech or similar deivce to compare what kind of mph you are picking up through various points along the 1/4 mile.
 

·
Administrator
Joined
·
17,259 Posts
My former T78 Supra with 15 PSI on stock fuel was certainly slower than a well running BPU Supra for anything but a top end race. That turbo won't do anything special until you get to about 18 psi and up, which is not recommended for stock fuel. Until then you just get a lot of lag and no real top end benefit.

Steve T.
 
G

·
Yeah what Steve said, careful pushing the stock fuel on larger turbo....get a damn set of injectors and another pump, its not that expensive....definitely beats replacing or repairing the block.
 

·
Registered
Joined
·
453 Posts
Discussion Starter · #10 ·
Thanks for the replies guys this helps out alot. Well im not too worried about hurting anything right now cuz i should have aem and the works here in about a month. And my car isnt driven that often. thanks
 
1 - 10 of 10 Posts
Top