Supra Forums banner

1 - 6 of 6 Posts

·
V-tec JUST KICKED IN!!!
Joined
·
715 Posts
Discussion Starter #1
Recently adjusted the Tein flex dampening force from 14- 12 F and 8 - 10 r. The car handles fine but seems to produce a small squeeking sound when compressing. Anyway to fix this or would it go away after a while?
 

·
Last stock TT on Earth
Joined
·
625 Posts
The sound might be coming from your solid pillow mounts. If you change the setting back does it go away?
 

·
V-tec JUST KICKED IN!!!
Joined
·
715 Posts
Discussion Starter #3
I'll try this, this weekend. sorry I park far away from home. If lets say the sound goes away what does that mean. If it doesn't do I need new mounts from Tein? Thanks for your help.
 

·
BLACKOUT
Joined
·
1,864 Posts
come to think of it , is there a recomended setting for the flex coilovers ? i have mine set at 16 all the way arround and dont see any difference unless i drop it to the lowest setting
 

·
Last stock TT on Earth
Joined
·
625 Posts
^I wouldn't use the highest settings or the lowest settings, usually things like this don't like to be set to their extremes. I just leave mine at 8-9 all the way around.
 

·
V-tec JUST KICKED IN!!!
Joined
·
715 Posts
Discussion Starter #6
come to think of it , is there a recomended setting for the flex coilovers ? i have mine set at 16 all the way arround and dont see any difference unless i drop it to the lowest setting
Anything above the 16 setting may damage your suspension. 16 is borderline safe. Also I believe japanese coilovers are generally hard to tweek. They are either too hard or too soft. I will definitely be going with a set of Bilsteins next time around. For now I must get rid of this damn squeaking! It's like there's a mouse in the wheel well.
 
1 - 6 of 6 Posts
Top