Supra Forums banner

1 - 20 of 22 Posts

·
Registered
Joined
·
171 Posts
Discussion Starter #1
Hey all, I have a tricky one here... i can't find anything that anyone has posted that resembles what I have going on. My car is drinking a ton of gas. I mean a ton. I get about 14-15 mpg, and I'm on the freeway mostly. I just got my exhaust and dp done, and I was thinking that it might be my ancient o2 sensor, so i changed that out, but it hasn't seemed to help. I also have a brand spankin new set of iridiums in, and a new set of moroso wires to go in. My car stinks like unburnt fuel when it's running, and every time I start it there's a plume of white smoke, but it doesn't smell like coolant (for all you harbingers of the bhg!). It runs fine, other than the occasional fuel cut code. The only thing I can come up with is that whenever I hit FC, I get a simultaneous code 31, which is for the AFM... if my afm was going bad, could it be telling my car to dump fuel? Is there anything else that clues you gurus off? It's making me crazy, not to mention raping my pocketbook!
 

·
SuperWhiteNinetyTwoMeat
Joined
·
1,001 Posts
I have been getting the exact same mileage. Im thinking it may be a combo of my extremely restrictive exhaust, that Im going to be replacing within the next month thanks to your help, and I believe my injectors are clogged. Do you have a ruff idle, which is also a sign of a bad afm, and will kill your gas mileage.
 

·
Registered
Joined
·
171 Posts
Discussion Starter #3
my ride isn't too bad, and my power is decent, at least to me it is. I really need to have someone drive my car who knows what it SHOULD feel like... The only other symptom is that sometimes my car idles really low, and other times it idles a little bit high, like just below 1Grand....

I thought that when I did my ehxaust/dp/plugs/o2 sensor that I would see some improvement, but I actually think that I smell more gas than ever.... I dunno....

Any other thoughts?
 
X

·
Guest
Joined
·
0 Posts
I have the exact same problems, does it ever do something funny when driving, like the revs jump all of a sudden?
 

·
Registered
Joined
·
171 Posts
Discussion Starter #6
nope, my drive is pretty smooth, good power and everything, afaik, just really crappy mileage, occasional FC with an occasional AFM code...
 

·
mount /dev/disk1s10 FFUU
Joined
·
903 Posts
Im an NA and i get this same issue, just no white smoke..yet. Car has 181k on stock injectors (i think). I just put a 3" crushed
tubed cat back on it, and im getting about 140 miles to a tank. I also
notice it starting to "missfire" at 3krpm or above. Almost its
hesitating or a loss of fuel. Im thinking the AFM. But i smell fuel
inside the cabin & when i walk around the car, i dont know if thats
normal but i was thinking maybe theres some seals on the fuel rail
somewhere going out (leaking gas)..

If the AFM checks out ok i was thinking the BVSV or one of the ECT
systems. I think my EGR is d/c from the previous owner, i havent
replaced the o2 sensor but ive had bad gas mileage since before i
fixed o2 sensor wire (was d/c). It just started getting really bad
lately(1-2 weeks).. I also noticed that the rubber boots for the
piping on my valve cover(s) are cracked.

I know the fuel filters are rated for the lifetime of the car, but
anyone got any ideas on what it could be, BTW i get no error codes..

Maybe i should sell this and get me a Lexus SC300 o_O
 

·
Registered
Joined
·
335 Posts
sabotage did you steal my car?
man i have everything exactly the same as yours(specs i mean)
and i think i get a around 200miles give or take.
i kno our take holds around 18gallons of gas and when i fill it up around 100miles i put around 8gallons to fill up the tank.

i calculated i roughly get around 11-13mpg, Hahaha and gas prices is out of this world NYC 93 at 3.70 a gallon.
Take off the Egr if your state is not strick on emission.

you read my mind, a sc300 could be a solution, but i am broke.

Back to wiredjosh question, find out what vaccum you pulling and if you have the time run a compression test.
Also if you have time do a leak down test for the sake of finding out if you have a BHG.
Find a fellow supra owner and ask to borrow the afm and see if that fix the prob.
 

·
Registered
Joined
·
581 Posts
Gentlemen: these engines are running super rich, which explains the raw gas smell. Contributors to poor gas mileage could be: vacuum leaks, old spark plugs, old spark plug wires, boost leaks, running higher than stock boost, most importantly, intake/exhaust upgrades, leaky injectors (cold start injector is prime suspect), etc. If you're making above stock power, your gas mileage will suffer (no news there). After fixing any vacuum leak, troubleshooting leaky injectors, an s-afc could help improve gas mileage while increasing power (carefully tuned, of course).
 

·
Rooftop Sniper
Joined
·
2,545 Posts
For me, the black wire to the o2 sensor harness was loose/not connected anymore so I hardwired it together and get around 18 mpg instead of the previous 15. I'm working my way up.
 

·
Not ur jizz, not ur bizz
Joined
·
6,571 Posts
if youre gettign code 51 on and off....id check your TPS for adjustment...if its off adjustment, it can cause the car to run pretty rich and backfire a good amount.
 
B

·
Guest
Joined
·
0 Posts
ive got a near stock n/a with 251,000 miles and mine runs fine and got 21 on the highway last time i calculated it. should i look forward to these problems?
 

·
Not ur jizz, not ur bizz
Joined
·
6,571 Posts
_bandit said:
ive got a near stock n/a with 251,000 miles and mine runs fine and got 21 on the highway last time i calculated it. should i look forward to these problems?

lots of miles, old car....even if its well kept care of, always be aware.

most of thses problems are stemmed from age....awesome to hear ur car is doing so well tho.
 

·
mount /dev/disk1s10 FFUU
Joined
·
903 Posts
CSR Ma71 said:
For me, the black wire to the o2 sensor harness was loose/not connected anymore so I hardwired it together and get around 18 mpg instead of the previous 15. I'm working my way up.
mine too, replaced that gas mileage is a tad better so far ive gone about... 105-110 miles on half a tank.. thats 12 MPG so far... which is better then what i used to get but still.. its horrid. Im replacing spark plugs/wires this weekend.. the cars misfiring at higher RPM around 4kish.. youll feel the car stop accelerating and almost start putting like its trying to go but it just cant... But slightly after 4k it will pull and be right into the game and start accelerating faster. My old capri xr2 did this and i replaced the sparkplugs after that it worked fine. I hope this is the sameway :(

how do you check for leaky injectors? Or the knock sensor..

Keep in mind this is an almost stock 86.5 NA
ive got the stock catforward exhaust but its 3" exhaust from the cat back. besides that engine internals are stock.
 

·
Registered
Joined
·
581 Posts
sabotage said:
mine too, replaced that gas mileage is a tad better so far ive gone about... 105-110 miles on half a tank.. thats 12 MPG so far... which is better then what i used to get but still.. its horrid. Im replacing spark plugs/wires this weekend.. the cars misfiring at higher RPM around 4kish.. youll feel the car stop accelerating and almost start putting like its trying to go but it just cant... But slightly after 4k it will pull and be right into the game and start accelerating faster. My old capri xr2 did this and i replaced the sparkplugs after that it worked fine. I hope this is the sameway :(

how do you check for leaky injectors? Or the knock sensor..

Keep in mind this is an almost stock 86.5 NA
ive got the stock catforward exhaust but its 3" exhaust from the cat back. besides that engine internals are stock.

Mine started hessitating on hard acceleration right after replacing the spark plugs. A friend recommended I regap the plugs more carefully, that one could be gapped too wide. Sure enough, ragapped them, one was too wide, and the problem went away.
I've read here of guys getting 8-12 mpg. There's definitely something wrong with a car to be running that rich. Check for vacuum leaks, boost leaks, etc. Don't forget to make sure the intake accordion hose is intact. Later.
 

·
mount /dev/disk1s10 FFUU
Joined
·
903 Posts
yeah well vacuum leaks could be a big one with me.. i doubt boost leaks unless ive got a turbo.. and well i didnt know it. I do need to find why its running so rich. I dont feel like replacing a cat anytime soon..
 

·
FIX-R upper
Joined
·
567 Posts
what kind of gas u guys use?

my buddy had the same problem, because he was using 91 and 89 gas. basicly he would detonate all the time, you could clearly tell when he reved his enjine... those poping sound that every moron think r cool! ha!
 
1 - 20 of 22 Posts
Top