Supra Forums banner
1 - 12 of 12 Posts

·
hardtopper
Joined
·
2,409 Posts
Discussion Starter · #1 ·
To everyone who doesn't know. Frank helped me out by going WAY out of his way to tow my car because I broke at MIR in our private rental today. Frank towed me one and a half hours north to Ryan23's house, then AlexD and his Dad towed his own car home another 45 minutes north because he broke too. They drove back down to ryans house to pick up my car and tow it to the maryland line where Mike91t picked me up and towed me back to his house.

I got to see the back of three trailers today and APPRECIATE it VERY MUCH!!!!

After Mike and I got back to his house he put the car on a lift and he just started looking over it and found the problem quite quickly. It ended up being a cap that broke which had capped off the coolant line to the IAC motor. The guy who put the block in originally half assed the wrong sized clamp and cap/plug.So I am back running again. Thank you Mike!


It was thought to be the waterpump or waterpump gasket. because it was leaking wqater down the front side of the motor.
 

·
Sooooooo JDM
Joined
·
1,220 Posts
93HRDTOPTT said:
To everyone who doesn't know. Frank helped me out by going WAY out of his way to tow my car because I broke at MIR in our private rental today. Frank towed me one and a half hours north to Ryan23's house, then AlexD and his Dad towed his own car home another 45 minutes north because he broke too. They drove back down to ryans house to pick up my car and tow it to the maryland line where Mike91t picked me up and towed me back to his house.

I got to see the back of three trailers today and APPRECIATE it VERY MUCH!!!!

After Mike and I got back to his house he put the car on a lift and he just started looking over it and found the problem quite quickly. It ended up being a cap that broke which had capped off the coolant line to the IAC motor. The guy who put the block in originally half assed the wrong sized clamp and cap/plug.So I am back running again. Thank you Mike!


It was thought to be the waterpump or waterpump gasket. because it was leaking wqater down the front side of the motor.
Josh -
Good to hear it was something easy! Are you using vaccum caps to seal of water lines? If it's not something that can be welded, I recommend using a short piece of hose with a bolt/rtv/clamp. I've never had one leak. Vaccum caps will always, eventually, leak. Sorry for the misdiagnosis....there is only so much you can do on your back at the track, armed with a penlight :D

Ryan
 

·
Registered
Joined
·
1,638 Posts
Glad to hear you made it home ok Josh. It was a bitch to get in there to tighten the clamp so keep an eye on it.

Ryan, it would have been a real bitch to see lying on your back. The coolant did look as though it was coming from the front bottom of the engine but once on the lift you could look up the side of the block and see the source. And Wagner did use vacuum caps but I lucked out and remembered I had a piece of hose that would fit and stuck a bolt in it :)

Mike
 

·
hardtopper
Joined
·
2,409 Posts
Discussion Starter · #6 ·
Ryan23 said:
Josh -
Good to hear it was something easy! Are you using vaccum caps to seal of water lines? If it's not something that can be welded, I recommend using a short piece of hose with a bolt/rtv/clamp. I've never had one leak. Vaccum caps will always, eventually, leak. Sorry for the misdiagnosis....there is only so much you can do on your back at the track, armed with a penlight :D

Ryan
NP ....It was a good misdiagnosis. I am just glad it wasn't something worse.

Mike, everything looks fine and I drove it a little this morning. Pulls great and the A/F ratio is holding at 11.9-12 to 1 in third and fourth gears! and no breakup from being too rich!


If any of you EVER need any help just let me know! I owe all of you a couple!
 

·
Registered
Joined
·
3,688 Posts
93HRDTOPTT said:
NP ....It was a good misdiagnosis. I am just glad it wasn't something worse.

Mike, everything looks fine and I drove it a little this morning. Pulls great and the A/F ratio is holding at 11.9-12 to 1 in third and fourth gears! and no breakup from being too rich!


If any of you EVER need any help just let me know! I owe all of you a couple!

How about you buy dinner at Fogo de Chao for all of us. J/K
 

·
hardtopper
Joined
·
2,409 Posts
Discussion Starter · #8 ·
Alex D said:
How about you buy dinner at Fogo de Chao for all of us. J/K

Damn!!! $$$$$ Thaank god that place is all you can eat our I would be broke taking your ass there! :lol:
 

·
Flame Thrower
Joined
·
961 Posts
Im glad to see that it was something minor and not a major PITA! Good to see that you're back up and running again! How are you making out with that one wheel locK? Were you able to get it off or get a new key for it? Let me know how it turns out and if you need anything!

Ryan
 

·
hardtopper
Joined
·
2,409 Posts
Discussion Starter · #10 ·
Supra_404 said:
Im glad to see that it was something minor and not a major PITA! Good to see that you're back up and running again! How are you making out with that one wheel locK? Were you able to get it off or get a new key for it? Let me know how it turns out and if you need anything!

Ryan

Ordered a new key today. $22.00, what a ripoff! When I get the key if I mail them back the other key they will refund me. PITA!!!!
 

·
No Ego or Arrogance!!!!!!
Joined
·
744 Posts
I'm glad its was something simple Josh,and you are welcome,you would have done the same for me,next time bring a trailer and go for 30 psi like I will on my single set up and use the 2 step, it makes it easy to launch.
 
1 - 12 of 12 Posts
Top