Supra Forums banner
1 - 15 of 15 Posts
G

·
Discussion Starter · #1 ·
Ok so I've had my supra for like 4 months now and am still unable to solve this idle problem, have come back to these forums numerous times for help but to no avail :(

I just got my car back from the mechanic who thinks it's the "idle stepper motor" causing the problem. I didn't even know there was an idle stepper motor... anyway he says it could be "sticking" which is causing the idle to fluctuate. He has quoted me AU$900 for a new one but first I want to know if anyone else has ever heard of this before? I have read nothing about the idle stepper motor in these forums.

I have already tried replacing spark plugs, a new idle air controller, cleaning throttle body and looking for vacuum leaks which there seems are none. I don't think it could be the MAF cause Jap supras don't have MAF's I don't think....

( 93 NA Supra - 5sp manual )
 
G

·
Discussion Starter · #6 ·
that's exactly what happens. if i turn the car off and on it goes back to normal. so it's definitely this idle stepper motor thing then ??
 

·
Registered
Joined
·
124 Posts
I don't know if this will help at all but I had an idle problem after I put a K&N drop in filter in the stock air box. It would idle really low and stall sometimes at a stop. All I did to fix it was to take off the cover from the stock air box. Now it works great.
 

·
Registered
1995 Toyota Supra NA
Joined
·
175 Posts
How do you fix it though? My 95 does the same thing and once it stalls out and I turn it on ts fine. But that isn't the best way to fix it in my opinion. How can one theoretically turn the idle up electronically?
 
G

·
Discussion Starter · #12 ·
SuPraonPs said:
azazel61 Does your revs just drop under 500 and cause the car to shake an almost stall or what ?
sometimes it does that but lately it's been idling up over 1000rpm, sometimes even 1200rpm. if i turn off the car and back on it goes back to about 700 until i rev it again.
 

·
Hardtopper
Joined
·
13,043 Posts
It's the idle stepdown - is the car throwing any codes? Mine didn't when the sensor went bad, Toyota diagnosed it and found out the problem and had it replaced
 
G

·
Discussion Starter · #15 ·
kirk_mk3 said:
It's the idle stepdown - is the car throwing any codes? Mine didn't when the sensor went bad, Toyota diagnosed it and found out the problem and had it replaced
no codes - so there is an idle stepdown sensor? or is it the idle stepdown motor ? ive never heard of an idle stepdown sensor before
 
1 - 15 of 15 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top