Supra Forums banner

1 - 3 of 3 Posts

·
6M-GTE
Joined
·
34 Posts
Discussion Starter #1
ok so I've noticed lately that when my car idles, and this usually only happens on hot days, or when the car has been running for a long time (say at the end of a highway trip) when I come to a light or something and sit at idle, it'll just start idling lower until it stalls. also, its kind of hard to explain, but when I accelerate, there seems to be a delay, or lag from the gas, which gives me slow acceleration at the bottom end of the rpm range, and rough shifts, since the gas doesn't seem to kick in right away after a shift..
any ideas as to what the problem could be?
 

·
Registered
Joined
·
215 Posts
I have a similar problem, my car was doing that and I kind of assumed it was something with the throttle linkage. My ideas were also brought into more light when my car would start reving at 3k no matter what even if gas wasn't pressed down...that was fun lemme tell you. Turns out the plates where your throttle cable like links around for cruise control or whatever else were getting stuck together. I pretty much had to keep pulling over and pulling them apart. I would suggest maybe making sure nothing is sticking...not sure if this is a good idea but maybe wd40 the cable if it is sticking a bit.
 

·
6M-GTE
Joined
·
34 Posts
Discussion Starter #3
hmm, well my cruise control is not functioning, the cables are all disconnected, so I'm really not sure what the problem is..
 
1 - 3 of 3 Posts
Top