Supra Forums banner

1 - 8 of 8 Posts

·
RoastBeefCurtain Commando
Joined
·
6,015 Posts
Discussion Starter #1
I took my car on a trip to Ohio this weekend and prob put over 1k miles on it over the weekend.
I changed the oil before I left and the oil pressure was nice, stuck about 40psi above 3k which is higher then its been previously.

The whole way down there the car ran great. Oil pressure stayed pretty high. Nothing to be concerned about.
I ran it around all weekend and hard and ran great.
I checked the oil Mon morn before we left and the oil still looked great. Im like damn , I didnt lose any oil and didnt burn any the whole weekend. This is great.

So on the way home i see the oil pressure going down little by little as the hours go by on the highway. I stopped a few times at rest stops and it just makes it more difficult to check the oil on this dipstick at times. Only one side of the Dipstick reads. Ughhh. thats another problem in itself.
So I would just add some oil at rest stops and the pressure would go up a little, but not like before. I have a hard time believing i beat it around all weekend and lost all that oil just from a few hours on the highway and didnt the whole trip down and all weekend.
Could the oil pressure sensor be going bad?

Another thing that started too is when i start the car cold the boost gauge reads 0 for a little. When i rev it up to try and get it to set back I hear compressor surge like a Mofo. After like 1/2 a block of driving it goes back to vac fine and runs great then. I thought it was the boost gauge at 1st, until I heard the extreme compressor surge

Sorry for the book, but its best explained with more detail IMO.
Let me know what everyone thinks.
Thanks.
 

·
JZA70 448 rwhp everyday
Joined
·
2,994 Posts
check your wastegate vac line...while ur down there take a look at your oil pressure sender.

~scott
 

·
RoastBeefCurtain Commando
Joined
·
6,015 Posts
Discussion Starter #4
i just quickly poked around while at a pit stop and all the vac lines looked good. I just peaked down at the WG line and looked ok. I didnt take anything apart yet though.
Is there a way to test the Oil pressure sender?

Compressor surge is kinda hard to explain. Kinda like the air air coming from the turbo echoing. I cant explain it, but i know the sound
 

·
RoastBeefCurtain Commando
Joined
·
6,015 Posts
Discussion Starter #5
another thing I guess to be expected from going constant 80-90mph for hours straight is that my rad overflow spit up some coolant at stops. I guess too much pressure built up? Never over heated or got even close to it. But that concerned me too. The overflow tank has too much in it i thnk though. I always thought it had too much in it, but i never drained any out. Thats prob it though.
 

·
Not ur jizz, not ur bizz
Joined
·
6,571 Posts
7M-Boost said:
what does compressor surge sound like?

TOo toO TOO ToO
 
1 - 8 of 8 Posts
Top