Supra Forums banner
1 - 19 of 19 Posts

·
Registered
Joined
·
496 Posts
Discussion Starter · #1 ·
I am hitting fuel cut right around 8-9 psi. I have checked for boost leaks and me and my buddy are stumped. My friend thinks that the diaphram is ripped or torn. I did put washers in the wastegate. I put 4 on each side and was only boost like 9 psi max. I have a full 3" exhaust, jbl turbo elbow, intake and joe p MBC. Somebody help us out. THanks
 

·
Premium Member
Joined
·
6,130 Posts
waddup dude, I really doubt its a torn diaphram, seems more like a boost leak, check the usual suspect... the lower IC pipe or the coupler at the TB to 3k pipe, on a side note torn diaphrams leds to pregnancy... :(
 

·
Registered
Joined
·
496 Posts
Discussion Starter · #4 ·
The only thing that we haven't done is take the intercooler hose off that runs off of the turbo. We have got under the car and felt around as best as possible but haven't taken it off yet. I have had all of the pipes off and replaced the stock intercooler with a jdm. I don't know what else to do. It is really annoying that I can't make anymore than 9 psi and when I shift hard if I have the boost controller off I hit FC. Whats up??
 

·
Premium Member
Joined
·
6,130 Posts
btownboy said:
The only thing that we haven't done is take the intercooler hose off that runs off of the turbo. We have got under the car and felt around as best as possible but haven't taken it off yet. I have had all of the pipes off and replaced the stock intercooler with a jdm. I don't know what else to do. It is really annoying that I can't make anymore than 9 psi and when I shift hard if I have the boost controller off I hit FC. Whats up??
how's your BOV? aight peace
 

·
Registered
Joined
·
496 Posts
Discussion Starter · #6 ·
well I could blow through both sides of my old blow off valve so I got another one off of this jdm car, and it seems to be ok. But I still had the same problems there was no change in anything. I am getting code 34 turbo preasure code(stored code) but that is from fuel cut right? Thanks everyone
 
Joined
·
3,796 Posts
BoostAddctn said:
.... on a side note torn diaphrams leds to pregnancy... :(
Haha I was thinking the same thing!! lol :D
 

·
Registered
Joined
·
496 Posts
Discussion Starter · #9 ·
So do you think a torn diaphram would make me hit FC at 9 psi? I just wanted to make sure that isn't totally out of the question. I am almost positive it isn't a boost leak, we have taken off most of the hoses and checked them. Has anyone had any similar problems. Also the mechanic that installed the mootor for me doesn't know alot about imports. Thanks everyone
 
Joined
·
3,796 Posts
try different afm electronics.
 

·
Super Moderator
Joined
·
11,710 Posts
a torn diaphragm might limit you to 9 psi, (side note: I've never heard of this happening) but if you're hitting fuel cut at 9 psi that's because the engine thinks you're getting more air into the motor than you actually are. This means you have an intake leak or a faulty AFM.
The biggest suspects are the IC pipes and the BOV. If that's not the case, check/replace the gaskets on the intake manifold and the the throttle body.
Another culprit could be the IAC seal/bolts, and perhaps the EGR port on the back of the intake mani.

Trying another AFM would not hurt if there's one handy.

HTH
 

·
Registered
Joined
·
496 Posts
Discussion Starter · #12 ·
I am also running a bit lean does that make any sense? I have factory fuel and on a hard 5th gear pull I can hit 1400 egt after turbo at about 4000 rpms. I am checking the diaphram tommorrow to see if its bad. I'll let everyone know whats up. Thanks for all the help!
 

·
greasemonkey
Joined
·
3,144 Posts
its most likely the hose thats on the turbo. pull it off and check it. it is very common for it to crack. as for running lean, in 5th gear at high rpms that is alot of load and airflow. most likely the stock fuelpump just cant keep up. if you stay at max boost too long in 5th youll prolly melt something. seen it happen too many times.
william
 

·
Registered
Joined
·
496 Posts
Discussion Starter · #14 ·
I plan on pulling off the elbow tommorrow, I guess I need to jack up the car to do so. I'll let you know whats up. Also how slow are the autometer egt gauges? From a dead stop I won't hit over 1250 until like 3rd gear. I don't understand how my egts are low in 1st and 2nd when I am still boosting 8 psi and 5000 rpms. Thanks
 

·
Registered
Joined
·
496 Posts
Discussion Starter · #15 ·
I pulled the hose off of the turbo, no cracks or rips or anything. Is it possible to still be leaking? I have had off all of the intercooler hoses and none of them are damaged and they all have new hose clamps. Is it still possible for them to be leaking? Thanks everyone
 
G

·
How about the plastic IC hose...the one that goes into the fender...that might have a crack or split in it...and where in Nashville are you located at?
 

·
Registered
Joined
·
496 Posts
Discussion Starter · #17 ·
ok, here is a frigin news flash. I decided to take off the manual boost controller and just run a hose from the turbo to the actuator like the factory set up. Guess what.... if I slam it hard from first to second gear I hit fuel cut at about 8 psi maybe 9. The only thing I can think of is the afm. THanks for everyones help, p.s. I live in Kingston Springs now, I use to live in Bellevue that west of Nashville about 20 mins. Thanks
 

·
Registered
Joined
·
496 Posts
Discussion Starter · #19 ·
thanks pearly white

Thanks everyone for all of your help, I finally got the hard plastic pipe out of the fenderwell and found that it has 2 cracks in it. So I put some epoxy on the cracks and I am boosting about 11 psi now. But I have noticed that on occasion I feel lack in power. It seems like when it goes into boost it doesn't fell like it should. It doesn't pull as hard as it should. At 2 pounds of boost it feels as good as 11 psi sometimes. Anyone have any suggestions on what that is? Thanks for all of your help!!!!!!!!!!!!:)
 
1 - 19 of 19 Posts
Top