Supra Forums banner

1 - 13 of 13 Posts

·
Senior Member
Joined
·
1,020 Posts
Discussion Starter #1
I think the trac button I have in my 94 TT is broken.

The button goes in but it comes out to the same spot every time. Was wondring if the button is sapposed to stay in when pushed? ( Bought the car with it pushed in )

The traction control does work in my car, and when the button is pushed no lights change on the dash...

ny help would be appreciated...
 

·
dank
Joined
·
409 Posts
I've got the EXACT same issue. I'm glad I've had TC in some situations, but I'd also like to turn it off, but I CAN'T. Sucks.
 

·
Super Moderator!!ON PATROL ALL OVER!!
Joined
·
10,459 Posts
the button is suppose to work like that .

but if you bought it and it was in it might be damaged also try taking the dash out and check to make sure its connected.
 

·
Senior Member
Joined
·
1,020 Posts
Discussion Starter #4
Ranger498 said:
the button is suppose to work like that .

but if you bought it and it was in it might be damaged also try taking the dash out and check to make sure its connected.
yeh I have my dash out, and it was connected with nothing weird happening. I will porlly just order in a new button from toyota.
 

·
You Can [Not] Advance
Joined
·
2,871 Posts
For me when i push it to trun the TRAC off the light doesnt come on and say its off. It's still on.

Sometimes it does this sometimes it doesn
 

·
Super Moderator
Joined
·
10,498 Posts
Great pic Bill. Makes me proud to be the friend of a three-Supra family. Let me know how it goes on the dyno tomorrow.

Ken.
 

·
You Can [Not] Advance
Joined
·
2,871 Posts
Yeah i got tired of pushing the button and the TRAC still on. So i did just pull the fuse
 

·
BPU++
Joined
·
425 Posts
Ordering a new button from Toyota will not help. I had the same problem and traced it back to the circuit board on the top left which displays the check engine light, etc. It needed to be resoldered and ever since, I have had no problems.
 

·
Registered
Joined
·
45 Posts
I've pushed the button in and held as many have said, and no light comes on, and then dropped the pedal to the floor. Traction control light flashes and still kicks in. Will soldering this board 'complete a circuit' so that all works normally? Or then is there now wiring I need to be investigating?
 
1 - 13 of 13 Posts
Top