Supra Forums banner

1 - 16 of 16 Posts

·
Tom Henderson
Joined
·
1,236 Posts
Discussion Starter #1
I have traction problems in first and ALL of second..and when i go into third it spins out for alittle. I have 18x10s in the back with nitto NT555. I was just seeing if any other bpu's have that problem. I've given rides to 2 other supra owners..one is a bpu with 9.5 in the rear with nitto NT555's and my other friend who is a bpu+++ with stock wheels in the back and they both say they get really good traction meaning they would only cherp second.. I am gonna dyno it to see what kind of numbers would come out.. I just wanna see if any other supras had that problem and if they had high dyno results..its not really a problem but i am just curious..

-Tom
 

·
Supporting Vendor
Joined
·
4,400 Posts
AznSupraTT said:
I have traction problems in first and ALL of second..and when i go into third it spins out for alittle. I have 18x10s in the back with nitto NT555. I was just seeing if any other bpu's have that problem. I've given rides to 2 other supra owners..one is a bpu with 9.5 in the rear with nitto NT555's and my other friend who is a bpu+++ with stock wheels in the back and they both say they get really good traction meaning they would only cherp second.. I am gonna dyno it to see what kind of numbers would come out.. I just wanna see if any other supras had that problem and if they had high dyno results..its not really a problem but i am just curious..

-Tom
is the other guy with 555's on 17's or 18's? part of it could be your reduced sidewall. if youre on 30 aspect ratio, youre probably gonna spin a bit, aside from the fact that i dont think 555's are actually all that sticky. how wide are youre tires? this has a lot more to do with grip than the width of your rims.

the bpu+++ on 17's has more sidewall than you do, and possibly better tires,

another thing to look at is which of you (if any) are in ttc.

i light em up rather easy...im on 265/40R17's and on pump gas i still smoke at the top of second on a cool day. and thats on the lag of a 4 row/ttc. i gain 80rwhp from 4100-4300rpm...

Mark
 

·
Old School
Joined
·
4,014 Posts
I have fairly strong stock twin car, on normal street radials it would light the tires up on a 2nd gear roll, but switching to BFG drag radials was the cure. No real spin at all from a roll at any speed in any gear, they even hook OK in first from a 20 mph punch. No spin when upshifting either, beyond a brief chirp.
 

·
Registered
Joined
·
4,293 Posts
It is the 18's, not good for traction! No sidewall flex. The only thing worse for traction than 18's are 19's! I have seen good results from the BFG G-force DR's in 18" size.

Also, the Nitto DR's work well when hot, but horribly when cold! I have been surprised many times with the back end kicking out at 50 MPH when it is below 50 deg!

Al
 

·
Moderator
Joined
·
3,148 Posts
Two things highly affect grip. There are other things, but these are two often over looked.

1. Cold weather. Once it gets below 70 degrees, there is no more full throttle in 2nd.

2. Heat cycled tires. If your tires are about half to three quarters worn they lose a large part of their grip. It is amazing the added grip of new tires. I have run a best of 2.09 second 60' with worn tires. With the same model tire, at the same track, in the same size and on the same rim I ran several 1.9 60' times.

Just my two cents.

Later, Steve
 

·
Supporting Vendor
Joined
·
4,400 Posts
Steve, in tire or wheel threads, your two cents is probably worth about a buck fifty :)
 

·
Moderator
Joined
·
3,148 Posts
LYTLdiablo,

Thanks. :)
 

·
Registered
Joined
·
2,705 Posts
Josh S said:
A lot of it may have to do with the cold weather. I have traction issues now in the cold even with nitto drag radials on the street.

I agree with Josh here as the other nite
coming home from the movies at about 2am, it was about 35-40deg. out. When i punched it and #2 turbo came online, i was going sideways. I was having very bad traction issues. I'm also on 18's too, that didnt help too much either.


-Phu
 

·
Tom Henderson
Joined
·
1,236 Posts
Discussion Starter #11
i was just seeing if i had a strong bpu..cuz my friend had 19's and didnt get as much spin as me and my other friend also said he doesnt get as much wheels spin as me.. just like you guy said i punch it in second and the backend just flies out..haha..
oh yea thanks for the info steve..

-Tom
 

·
Registered
Joined
·
346 Posts
Sounds about right to me. At straight bpu I had terrible traction, but also terrible tires. My supra had kumho 712's on the stockers when I bought it so I used those for awhile.....no traction through 2nd at all, and a decent amount of spin in third if I was at 18psi with 100 octane. Stomping it from a roll in second would light 'em up.
 

·
Supporting Vendor
Joined
·
4,400 Posts
have you dyno'd? i wonder what the highest bpu pump gas is...probably around 420-430?

oh well...point of the matter is, i need race gas...
 

·
Supporting Vendor
Joined
·
4,400 Posts
lol you should pick up about 20-25 with those...was that SAE?
 

·
Tom Henderson
Joined
·
1,236 Posts
Discussion Starter #16
when i bought the car it had a jet chip installed..and i figured out that it was tripping the engine check light and making the car run like shit...i am getting a 94 ecu from someone so i think it will help a bit..
 
1 - 16 of 16 Posts
Top