Supra Forums banner
1 - 14 of 14 Posts
G

·
Discussion Starter · #1 ·
just got my trans rebuilt, and when i'm at a dead stop, and i go on a roll, it shifts from first to 2nd, but from second to third it shifts but at a high rpm, i checked the fluid, is their a sencer that i need to look at :dunno:
 
G

·
Discussion Starter · #4 ·
well, i got it rebuilt from sound performance, and i know that they did a great great job, it shifts manually fine but when i get on it from a stop until it shifts to second the rpms go way up and then it shifts hard, no noise that i can hear of? is their something else that could it make it not shift?
 

·
Yes, brothers own Supras
Joined
·
1,910 Posts
Yes, the converter could be the problem. Why was the tranny rebuilt? Is that the same converter u had before it was rebuilt?
 
G

·
Discussion Starter · #7 ·
i went single, so i decided to play it safe and send the trans out for an upgrade, along with a new 3200 stall converter. everything is new.
 

·
Don't touch the watch.
Joined
·
314 Posts
SteelCitySupra said:
I am not a fan of Sound Performance's work and that sounds like what the problem is.
Just because Sound Performance left a bad taste in your mouth doesn't mean you need to parade around the forums trashing them. :rolleyes:

I am a fan of Sound Performance's work and they probably have nothing to do with the problem.
 

·
NFA Pimp
Joined
·
2,734 Posts
94 slow supra said:
just got my trans rebuilt, and when i'm at a dead stop, and i go on a roll, it shifts from first to 2nd, but from second to third it shifts but at a high rpm, i checked the fluid, is their a sencer that i need to look at :dunno:

Sorry to ask such a simple question but how did you check the tranny fluid? Was the car running or not?
 
1 - 14 of 14 Posts
Top