Supra Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
216 Posts
Discussion Starter #1
my engine check lit up...and i pulled the codes..it reads as follows
35-turbo pressure sensor
41-throttle position sensor
47-sub-throttle position sensor
can anyone give me some info on how to either try and fix this.. like how i would go about checkin parts...or how much you think it would cost to fix these probs..thanks
 

·
Very Senior Member
Joined
·
9,964 Posts
Do you have the service manuals?
I had the dealer replace and CALIBRATE the throttle position sensor. I could replace it but didn't have the equipment to calibrate it. It didn't cost too much. ($65? - I forget).
 
Z

·
Guest
Joined
·
0 Posts
vicksupra is right on code 41/47, look at the little paint toyota has originally put on the screws of your throttle position sensor, has the paint crack or the screw moved? if so, it has been adjusted before and its not closing/opening 100%. I bet you get weird idle sometimes during cold start?

code 35 has to do with your turbo pressure sensor, check your BCC voltage output if you have a BCC. if not, check your actual turbo pressure sensor located on intake manifold above #3-#4 injector.
 

·
Registered
Joined
·
216 Posts
Discussion Starter #4
thanks alot..i'll do that...today...and yea..i do have a bcc..maybe that will explain why i get weird boost conditions..sometimes it just won't boost...thanks..again..i'll post if anything else happens...you guys have been very helpful..
 
1 - 5 of 5 Posts
Top