Supra Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
191 Posts
Discussion Starter #1
a friend of mine found me a cheap supra yesturday that i can part out for my car...(no exhasut sytem/no back bumper)

so the first thing i check was the turbo,(i was lucky enuff that the dp wasnt there)

-the intake turbine VERY LITTLE TO ALMOST NO shaftplay side to side but NONE back and forth.

the exhaust turbine has NO SHAFTPLAY...

anyways i was wondering why the turbo that has no shaftplay wont spin freely? its spin but stops realy quick...
-oh did i mention that the car was sitting outside of a shop for a while.

if i were to run this is my car would it loosen the turbine?
or its not safe to run it?


any ideas?
 
7

·
Guest
Joined
·
0 Posts
also it might be coked up take off the oil return line looy inside where the bearing is its probally got some buildup spraya good penetrating oil then clead with card cleaner if you got commpressed air blow it out really good
 

·
Registered
Joined
·
191 Posts
Discussion Starter #5
73LEVIN said:
also it might be coked up take off the oil return line looy inside where the bearing is its probally got some buildup spraya good penetrating oil then clead with card cleaner if you got commpressed air blow it out really good
does wd-40 count as penetration oil?

and whats a card cleaner?
 

·
Registered
Joined
·
3,727 Posts
he meant carb cleaner
 

·
Premium Member
Joined
·
5,301 Posts
ZaZZn said:
just leave he damn thing alone...

After you start the car and WARM up the thick oil it will be fine.
Werd. Don't listen to the other crap that was said in here. Just start it and run it and once warm oil gets in there, you will be fine. Don't worry about it.
 
1 - 8 of 8 Posts
Top