Supra Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
213 Posts
Discussion Starter #1
Recently took my engine out due to severe knocking.
Turned out I had spun a bearing and cracked my crank.
My piston to bore clearance was 8 thou so I have been getting quite a bit of oil past the pistons and into the turbo’s.

To my problem:
I’ve been looking at the turbo’s today and there seems to be excessive play on the impellor wheel shafts on both turbo’s.
These turbo’s were reconditioned units from Universal turbo’s and have covered between 5 and 6 thousand miles. Neither have they been driven hard! But I can imagine the oil getting into them has not been doing them any good!
Unfortunately they are out of there warranty.
The play on the shafts is not enough for the blades to start catching the housing side walls but its dam close to them.

What are my options? can the bearings be changed only or is it a bit more complicated than that?

Any help would be much appreciated as I need to find the cheapest but correct solution. My Short Block is going to set me back £2000 for a start

Scott
 

·
Registered
Joined
·
61 Posts
Sounds like axial play is what you are worried about. Use a dial indicator to measure & compare to the factory specs.

Get a FSM & follow the instructions on where to measure axial play.
 

·
Registered
Joined
·
213 Posts
Discussion Starter #3
i checked the specs in the manual. it says there should be a maximum of 0.16mm axial play. i can tell by hand that it is more than this :(
 
1 - 3 of 3 Posts
Top