Supra Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
707 Posts
Discussion Starter · #1 ·
Whenever I get on the gas and floor the accelerator, my car will build boost until around 3.5k and then I can hear the turbo making a sputtering sound. Boost gauge still reads around 6 pounds (all stock), but I don't know how accurate it is. However it still reads at the same mark that it always did under boost, so I don't think it's a boost leak. It doesn't feel as powerful as it did before though. I checked the codes and the only one is a code 52, knock sensor, which has been there for a while and the car has not been acting up. Anyone else experienced this problem?
 

·
desufnoC
Joined
·
1,842 Posts
You don't think it's missing? There is plenty of extra load to spool the turbo when your missing, but it surely doesn’t mean your going anywhere fast.
 
G

·
Misfire maybe, or you think the noise is from the turbo, take the accordian hose off the turbo and check the turbo for bad shaftplay or something.
 

·
Not ur jizz, not ur bizz
Joined
·
6,571 Posts
fix code 52 and thank me later.

other causes....boost leak..and i think exhaust leak
 

·
Registered
Joined
·
707 Posts
Discussion Starter · #5 ·
I went out and wiggled the spark plug wires a bit, and the problem seems to be gone, or at least the car is back to how it was before.

Johnny Dangerously said:
fix code 52 and thank me later.
I was actually going to take care of this last weekend but didn't get to. I bought the connectors now I just need to take care of the wiring... what kind of wiring exactly should I ask RadioShack or some electronics store for? They have all sorts of speaker wire, but there are other criteria like shielded, blah blah blah that I'm not sure of.
 

·
eighty-7t on SM
Joined
·
444 Posts
i was having the similar problems. it turned out that one of the coils was out so i was only running on 5 cyls. missfiring up the ass! i now installed another coil, missfire gone! turbo spools just fine and no more stuttering.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top