Supra Forums banner

1 - 18 of 18 Posts

·
Registered
Joined
·
1,317 Posts
Discussion Starter #1
Ok I forgot to connect the hose on the wastegate and popped out my IC pipes. Now the turbo wines; boosts fine, but just doesn't kick as hard as it used to.

I'm figuring it's a dying turbo. Does anybody think otherwise?

Also every once in a while, there will be a puff of white smoke out of the exhaust when I crank and start the engine. Is this also a indicator of a dying turbo or is it something else?
 

·
Not so boring anymore
Joined
·
7,085 Posts
if it sounds like a superchager its time for a new turbo.. my friends died like that... would whine but didn't smoke no bent fins.. then next one smoked really bad, but didn't really whine that much and had bent fins
 

·
Project:: Reaper
Joined
·
1,401 Posts
that would be my turbo he's talking about. indeed it is time for a new one.

it started sounding like an 03 cobra for awhile then replaced it and the oil feed line got blocked by some gasket sealer and blew that one. now i have a hybrid tnetics turbo and the wastegate is sticking. turbo problems galore YIPPEE!!!


oh yea BTW the best way to tell i ofund out is to decel coming up to a stop sign or light, and down shiftr to 3rd then to second and let 2nd decel till the car almost stalls and push in the clutch. when i did this on my dying turbo a cloud of Oil Smoke would float past my car.
 

·
Destroyer of Turbos
Joined
·
4,461 Posts
pull your accordian hose and check for shaft play. sounds like death whine though...
 

·
Registered
Joined
·
1,317 Posts
Discussion Starter #8
MKIIINA said:
pull your accordian hose and check for shaft play. sounds like death whine though...
Yeah I'll probably check for shaft play when I get back home.

Hopefully it is just a boost leak of some sort. Although I kinda doubt it. lol.
 

·
Registered
Joined
·
1,317 Posts
Discussion Starter #9
I've been blessed by the car gods! It's not turbo whine! The supercharger like sound I was getting was from a soiled alternator belt from my previous blown cam seal. The belt would not start slipping until I reached a certain RPM... sometimes 1,500; 2,500; 3,000 rpms. This is why I thought it was turbo whine because it seemed to kick in when boost showed on the gauge, but fortunately the whine was just from a slipping belt.

I applied some orange hand cleaner from dollar tree all over the belt and that fixed the annoying whine. :)
 

·
Registered
Joined
·
1,317 Posts
Discussion Starter #11
RTA Supra said:
lol

You know what would be great? Spend the 15 bucks and REPLACE the belt :naughty:
I'll wait til it breaks on me. :nutkickhi

Besides I put it in this past summer... 9 months ago, less than 1,500 miles on it.
 

·
Destroyer of Turbos
Joined
·
4,461 Posts
lucky sob! great job man fixing your car :) congrats.
 

·
Supraless
Joined
·
998 Posts
I have that supercharger whine too but mine is in the shop right now getting the BHG fixed and a cracked manifold fixed also. So i guess i will be replacing the turbo too.
 

·
Is this thing on?
Joined
·
306 Posts
:rofl: hmmmm....... sounds to me like you need to replace the chrome muffler bearings as well. make sure you lube them well with orange cleaner tho thats the secret :rofl:
 

·
Registered
Joined
·
1,317 Posts
Discussion Starter #16
SupraDreamer44 said:
:rofl: hmmmm....... sounds to me like you need to replace the chrome muffler bearings as well. make sure you lube them well with orange cleaner tho thats the secret :rofl:

Heck yeah, orange "hand" cleaner is the real secret. You should try adding some in your engine oil, it'll fix that rod knock right up. :rofl:

Note: This is a joke. lol.
 

·
slowly giving up...
Joined
·
1,069 Posts
i think i now have the death whine. some of my impeller blades are chipped, i have shaft play, and when i let off the gas after boosting, it sounds like there's a cop behind me... :(

time for bigger and better things.

-shaeff
 
1 - 18 of 18 Posts
Top