Supra Forums banner

61 - 80 of 89 Posts

·
Registered
1987 MA71 R154 Pearl White, Blue Velour
Joined
·
537 Posts
Ok, fair enough. Just don't create more work for yourself. The car will keep you fully employed for sure! :ROFLMAO:
 

·
Registered
Joined
·
182 Posts
Discussion Starter · #63 · (Edited)
Did the front and rear struts over the last day and a half, kinda annoying doing it for the first time but once the 1st one of each front and rear was done the 2nd was smooth.. Used my spare struts i had so who knows how good they will be..

Just changed my oil again because the oil psi was kind of low, made a big difference changing it.

700 miles in daily driving it!


Sent from my LM-G820 using Tapatalk
 

·
Registered
Joined
·
182 Posts
Discussion Starter · #64 ·
Also my stupid alarm keeps going off randomly and or randomly stops my starter from engaging..read some stuff up on how to disable it , so that's next.

Sent from my LM-G820 using Tapatalk
 

·
Registered
Joined
·
182 Posts
Discussion Starter · #65 ·
Am I crazy or are these front control arm bushings gone?


Sent from my LM-G820 using Tapatalk
 

·
Registered
Joined
·
1 Posts
Update here: One thing i forgot to mention is the car came with a TON of extra parts, such as all manuals i need, struts with TEMS, Front and rear seats in nice blue cloth 9/10 condition, Side panels for the doors, brake calipers, whole A arms, a rear diff, a rack and pinion, two heater cores, a whole gauge clutser and more.... Check it out.

View attachment 248213 View attachment 248214 View attachment 248215 View attachment 248216 View attachment 248212


View attachment 248220
gauge cluster maroon.jpg supra parts garage.jpg supra josh sitting on tank.jpg
. overall parts.jpg 2nd overall parts.jpg supra manuals.jpg

Progress on these, have attempted to get the maroon supra to start with no avail.. yet... It cranks great but my guess it's been sitting almost 15 years, the registration on the plates it has on expired in 2004. Ran a compression test on cyl 1 with over 130psi, going to check the other 5 cylinders tomorrow. Engine light comes on when key is turned on which is good, spark on cyl 1. The gas is bad, so I pulled the fuel tank and am going to swap over the fuel tank from the white one as it sits since I know that car runs. I took off the air filter housing to find a K&N air filter caked with dirt! Cleaned it out. Going to put brand new plugs and wires (brand new ngk wires came in the car) on and see what happens. Broke a lot of hoses, they are all very rotted. Definitely needs alot of TLC.
View attachment 248217 View attachment 248218 View attachment 248219
broken hose 7m.jpg valve cover shot maroon supra.jpg supra pulling fuel tank out.jpg
Hi...hey are you interested in selling your TEMS? do you know if they are working? I have a 1987 Supra Turbo in need of some!
 

·
Registered
Joined
·
182 Posts
Discussion Starter · #68 ·
Yeah I'd sell some TEMS, not 100% sure they work but they look in great condition and came off great looking shocks. Id say they will work.

Sent from my LM-G820 using Tapatalk
 

·
Registered
Joined
·
182 Posts
Discussion Starter · #69 ·
So update, haven't driven the maroon supra in two weeks due to me being ill, I ordered all new bushings for the car, and also got a transmission from a fellow supra owner Abe, got a great deal.
I also finally bought a shop crane and engine stand and picked up a rear sump oil pan for my 2jz, (which i am really not certain about with what i am going to do what so ever)

Anyway, supra still runs awesome, i need to get the passenger window to work, and also disable the alarm system because I am tired of disconnecting my battery every time I leave the car alone.

Also something somebody might be able to help narrow down, my idle is about 950rpms warmed up and goes down to 700 when in drive, seems high to me. Checked for vacuum leaks to no avail,when I unplug my iacv nothing changes, is that normal?



Sent from my LM-G820 using Tapatalk
 

·
Registered
Joined
·
182 Posts
Discussion Starter · #70 ·
I have a very loud droning/howling sound and powerful vibration from 58-70mph it deepens it's tone when I let off the gas and decelerate. It sounds like it's coming right from under the center consol underneath the car, but it's hard to confirm that. The steering wheel does not shake terribly, I just had the tires mounted and balanced (used). My transmission is slipping somewhat, but it doesn't seem to care if it's in gear or neutral. I just swapped the struts out, I also know the control arm bushings are nill. What are your thoughts?

Sent from my LM-G820 using Tapatalk
 

·
Registered
Joined
·
182 Posts
Discussion Starter · #72 ·
So I had a coolant leak recently and I discovered it was the heater control valve. Upon looking for a replacement I realized they are quite expensive.. So I had an idea of my own...





I filed it down and found a fitting that actually sort of threaded in..i then jb welded jt..


I then found another fitting to match the hose size,


I then grinded that down to round it off, well it was working for about 1 minute and then I was a little too rough on it.. And it broke. So I went back to the hardware store. And found a little better fitting for the hose size.. Jb welded it in.. And will try it out sunday , i have some confidence..





Sent from my LM-G820 using Tapatalk
 

·
Registered
Joined
·
1,016 Posts
I would not trust that. imagine it separating on the freeway ...

I would replace it with a straight up fitting (remove the valve) or find an oem quality replacement.
 

·
Registered
Joined
·
182 Posts
Discussion Starter · #75 · (Edited)
oem quality replacement? Both my supras heater control valves are broken, they are so old and brittle they are not reliable.
Sent from my LM-G820 using Tapatalk
 

·
Registered
Joined
·
182 Posts
Discussion Starter · #77 ·
I would not trust that. imagine it separating on the freeway ...

I would replace it with a straight up fitting (remove the valve) or find an oem quality replacement.
Madison I took your idea and did a straight fitting.

Sent from my LM-G820 using Tapatalk
 

·
Registered
Joined
·
46 Posts
From what I read, there is a replacement. Four Seasons Heater Valve #74850
Four Seasons Heater Valve #74850

This part IS a direct replacement part for our supra's. I ordered one for a 91 corolla and it came with the mounting bracket and lever arm on the valve. This is set up for a cable so all you need to do is change out the lever arm and install it on your supra.

$20 on Ebay sure beats $150 for Toyota, just need a little know how. Hope this helps at least one person.
 

·
Registered
Joined
·
1,016 Posts
-I thought there was a reasonable replacement as many cars run these, tnx for posting that up Jimbo
 

·
Registered
Joined
·
182 Posts
Discussion Starter · #80 ·
So still trying to pinpoint this vibration in the 60mph -70mph range. I jacked the rear of the car up and took it up to speed and still get very serious vibrations.. Wheels appeared to move a little so I took them off and still vibration when up to speed, it comes up the center of the car all the way to where the radio is. Which makes me think driveshaft... But looking at driveshaft it appears to spin straight and true. I put my ear into a funnel and touched the transnission (heard some vibration) the center support bearing for the driveshaft (heard no vibration) and the rear diff (about the same as the transmission)

I've noticed hard impacts on if i were to let off the gas and snap it back almost like a mount on either the engine or tranny.. Or something else is letting lose? Also when in the 65mph range if i let off the accelerator the vibration does seem to worsen for a second or 2.

Any tips for further diagnosing?

Sent from my LM-G820 using Tapatalk
 
61 - 80 of 89 Posts
Top